[Buri][Shira][PLMN]Can not register network by manual mode.

VERIFIED FIXED

Status

P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: sync-1, Assigned: anshulj)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:tef+)

Details

(Whiteboard: IOT, Spain, Ikura [NPOTB], Poland, Buri)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.037
 Firefox os  v1.0.1
 Mozilla build ID: 20130310070203.
 
 
 +++ This bug was initially created as a clone of Bug #408585 +++
 
 CONTACT INFO (Name,Phone number):
 yeyaping 02161460666-6128
 
 DEFECT DESCRIPTION:
 Can not register network by manual mode.
 
 REPRODUCING PROCEDURES:
 1.Present network A(001 01) B(208 01);
 2.Swith on MS, MS registers on network A(001 01) automatically;
 3.Select Settings-->Cellular&Data-->Network operator;
 4.Switch off 'Automatic selection', MS will show PLMN list, select any PLMN, MS show 'Connection failed' directly;-->KO
 
 EXPECTED BEHAVIOUR:
 4.MS should try to register on the selected network but not show  'Connection failed' directly;
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 5/5
 
 For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #408585 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
 DEFECT DESCRIPTION:
 
 REPRODUCING PROCEDURES:
 
 EXPECTED BEHAVIOUR:
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 
 For FT PR, Please list reference mobile's behavior:

Updated

6 years ago
blocking-b2g: --- → tef?
Hi, 

Blocking issue reported during certification in Spain, adding dep, already marked as P1. 

Thanks!
David
Blocks: 855322
Priority: P2 → P1
No longer blocks: 855322
Blocks: 855322
The build that this is reported against is quite old, relatively.   Does this still occur at the tip?
Flags: needinfo?(sync-1)

Updated

6 years ago
blocking-b2g: tef? → tef+
(Assignee)

Comment 3

6 years ago
Please provide android main logs and the radio logs by running the following command

adb logcat -b radio -b main -v time > log.txt
Flags: needinfo?(sync-1) → needinfo?(chengan.xiong)

Comment 4

6 years ago
anshulj@codeaurora.org, could you be the assignee? Or, should we assign this case to someone else? Thanks!
Assignee: nobody → anshulj

Comment 5

6 years ago
Created attachment 734567 [details]
manual network selection

Comment 6

6 years ago
(In reply to Anshul from comment #3)
> Please provide android main logs and the radio logs by running the following
> command
> 
> adb logcat -b radio -b main -v time > log.txt

Hi Anshul,
Attached you can find the log file attachment 734567 [details]. The behaviour is a bit different than the explained above. Now when you switch off 'Automatic selection' option, and the list of networks avialable is shown, it is not possible to select any of them. Tapping on any network name does not do anything.

If you need any other log, more info or whatever, please let us know.
It seems to works for me on Unagi. On which devices does it fails for you?
Unagi (at least with commercial RIL), Ikura and Buri.
(Assignee)

Comment 9

6 years ago
You are using a pretty old AU, could you please give it a try with the latest AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.070?
Assignee: anshulj → pgravel
Adding some colleagues and myself in CC

Updated

6 years ago
Whiteboard: IOT, Spain, Ikura
(In reply to Anshul from comment #9)
> You are using a pretty old AU, could you please give it a try with the
> latest AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.070?

Hi Anshul, 

We will test again with a newe RIL

thnks

Updated

6 years ago
Whiteboard: IOT, Spain, Ikura → IOT, Spain, Ikura [NPOTB]
(Reporter)

Comment 12

6 years ago
Not OK when take AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.070

Updated

6 years ago
Flags: needinfo?(chengan.xiong)
(In reply to Anshul from comment #9)
> You are using a pretty old AU, could you please give it a try with the
> latest AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.070?

I have tested a build based on AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.070 RIL and it is still failing.

Is there any other information or log you need?
Flags: needinfo?(anshulj)
(Assignee)

Comment 14

6 years ago
Isabel, from the logs I see that RIL is throwing an error for the request to select the network.

[0185]> SET_NETWORK_SELECTION_MANUAL operatorNumeric=2141
[0185]< SET_NETWORK_SELECTION_MANUAL fails by generic failure(2)

We are selecting the network with value 2141, however there is no such network returned by RIL when we query for the list of available networks.

[0176] < QUERY_AVAILABLE_NETWORKS  {long=Telefonica Moviles Espana,short=movistar,numeric=21407,state=current,long=Vodafone Spain,short=Vodafone,numeric=21401,state=forbidden,long=France Telcom Espana SA,short=Orange,numeric=21403,state=forbidden,long=Xfera Moviles SA,short=Yoigo,numeric=21404,state=forbidden}

It seems like there is an issue with a missing '0' (2141 instead of 21401). I am still looking at it.
Flags: needinfo?(anshulj)
(Assignee)

Updated

6 years ago
Assignee: pgravel → anshulj
(Assignee)

Comment 15

6 years ago
The issue is resolved in AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.078.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

6 years ago
Not OK when take AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.078
(Assignee)

Comment 17

6 years ago
Please provide the android main logs and the radio logs with the AU 78. Please also confirm that you are using the AU 78 by checking the firmware version in settings app -> Device Information.
Flags: needinfo?(sync-1)
(Reporter)

Comment 18

6 years ago
(In reply to comment #18)
 > Comment from Mozilla:Please provide the android main logs and the radio logs
 > with the AU 78. Please also confirm that you are using the AU 78 by checking
 > the firmware version in settings app -> Device Information.
 > 
 
 OK. We will check this PR in the latest version SW124-2 / SW125. And these version have taken AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.078. If have some problems, we will provide the refer radio logs.
Flags: needinfo?(sync-1)

Comment 19

6 years ago
Bug Solved with:
build: 20130426093145 
Ril: LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.085
Device: Inari
Status: RESOLVED → VERIFIED
(Reporter)

Comment 20

6 years ago
It is also not OK when use china-unicom card to test. Now on the
 sw126 which have taken "LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.085", ms can connect one network. But still have another problem:
 
 ---->There are several available networks(2g / 3g) for one sim-card. If we
 select one network, ms can connect it. But now we can not connect another
 available network.
(Reporter)

Comment 21

6 years ago
On the
 sw126 which have taken "LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.085", ms still can not register on Forbidden network.
(Assignee)

Comment 22

6 years ago
Due to recent changes to store MCC/MNC as strings instead of integer there were some changes needed in commercial RIL. The issue you are seeing should be addressed by AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.087.

Updated

6 years ago
Blocks: 869681

Updated

6 years ago
Whiteboard: IOT, Spain, Ikura [NPOTB] → IOT, Spain, Ikura [NPOTB], Poland, Buri
Summary: [Buri][PLMN]Can not register network by manual mode. → [Buri][Shira][PLMN]Can not register network by manual mode.
You need to log in before you can comment on or make changes to this bug.