449149-1a.html and 449149-1b.html reftests broken on b2g by bug 848939 or bug 844783

RESOLVED FIXED in mozilla22

Status

()

Core
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: philor, Assigned: jgriffin)

Tracking

Trunk
mozilla22
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

961 bytes, patch
Bobby Holley (parental leave - send mail for anything urgent)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

5 years ago
Personally, I had my money on tomorrow afternoon to be when we would break something in the currently-hidden b2g tests.

https://tbpl.mozilla.org/?tree=Mozilla-Inbound&showall=1&rev=24c95448c549 and then the downarrow to see it green on the push below, b2g reftest-4 got permaorange from the bug 848939 / bug 844783 push.

https://tbpl.mozilla.org/php/getParsedLog.php?id=20936524&tree=Mozilla-Inbound

The tests seem to be "an empty <audio controls> should look like something other than a blank page" so... I'm not even betting on which one of the two it is, just blaming both.
Do b2g reftests use reftest-cmdline.js? If not, they need to flip this pref:

https://hg.mozilla.org/integration/mozilla-inbound/rev/c5ad6568024d#l3.12
It may have also been the videocontrols.xml change. CCing dao and jaws in case they have any idea how that stuff might be different on b2g.
Bug 834931 is the most recent change to the video controls for b2g that I know of. David, do you have any ideas here?
Flags: needinfo?(dflanagan)
I tried various combinations of disabling XBL scopes (which could demonstrate the problem in comment 1) and switching my desktop build to TouchControls (comment 2), but couldn't reproduce the issue. Hopefully David has some ideas.
I'm not exactly sure what the question is, I don't have access to one of the blocked bugs, and I know next to nothing about our tests.

The appearance of the audio/video touch controls did change, so if this is an image comparison test, maybe it is not being compared to the correct thing? I suppose tests were turned off when I worked on bug 834931.

IIRC, Fennec and B2G share an xbl file for the touch controls, but they have separate CSS files.  See b2g/chrome/content/touchcontrols.css for the B2G controls.

Hope that helps, at least a little.
Flags: needinfo?(dflanagan)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 853949
(Assignee)

Updated

5 years ago
Blocks: 853024
(Assignee)

Comment 7

5 years ago
(In reply to Bobby Holley (:bholley) from comment #1)
> Do b2g reftests use reftest-cmdline.js? If not, they need to flip this pref:
> 
> https://hg.mozilla.org/integration/mozilla-inbound/rev/c5ad6568024d#l3.12

They don't; we'll need to add this pref here:

http://mxr.mozilla.org/mozilla-central/source/layout/tools/reftest/b2g_start_script.js#14
(Assignee)

Comment 8

5 years ago
Created attachment 728350 [details] [diff] [review]
Set dom.use_xbl_scopes_for_remote_xul for b2g reftests,
Attachment #728350 - Flags: review?(bobbyholley+bmo)
(Assignee)

Updated

5 years ago
Assignee: bobbyholley+bmo → jgriffin
(Assignee)

Comment 9

5 years ago
pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=56e846042591
(Assignee)

Comment 10

5 years ago
(In reply to Jonathan Griffin (:jgriffin) from comment #9)
> pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=56e846042591

This was green.
Comment on attachment 728350 [details] [diff] [review]
Set dom.use_xbl_scopes_for_remote_xul for b2g reftests,

Review of attachment 728350 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, but it's still kind of worrisome that this broke. I'll look into it.
Attachment #728350 - Flags: review?(bobbyholley+bmo) → review+
(Assignee)

Comment 12

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/d89e6ebf2a7b
Target Milestone: --- → mozilla22
https://hg.mozilla.org/mozilla-central/rev/d89e6ebf2a7b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.