If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Buri][WIFI]The icon display wrong after connected to AP

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: sync-1, Assigned: etienne)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #424482 +++
 
 DEFECT DESCRIPTION:
 The icon display wrong after connected to AP
 REPRODUCING PROCEDURES:
 1.turn on Wi-Fi,and connect to AP
 2.In the process of connecting to AP,the icon flow,but after connect to AP successfully,sometimes the icon also flow,sometimes the icon is normally->KO
 EXPECTED BEHAVIOUR:
 the icon should display normally when connect to AP successfully
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:2/5
 
 For FT PR, Please list reference mobile's behavior:
 
 AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.037
 Firefox os  v1.0.1
 Mozilla build ID: 20130310070203.
 
 ++++++++++ end of initial bug #424482 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
 DEFECT DESCRIPTION:
 
 REPRODUCING PROCEDURES:
 
 EXPECTED BEHAVIOUR:
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 
 For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Created an attachment (id=375709)
 pics
(Reporter)

Comment 2

5 years ago
Created attachment 730008 [details]
pics

Created an attachment (id=375709)
 pics
(Reporter)

Comment 3

5 years ago
Created an attachment (id=375711)
 pics
(Reporter)

Comment 4

5 years ago
Created attachment 730009 [details]
pics

Created an attachment (id=375711)
 pics

Comment 5

5 years ago
hi,

This issue is caused by  wifi 'icon.dataset.connecting'. When wifi status is
'connected', but signal level = 0, and now 'icon.dataset.connecting = true'.
This situation equals the CSS which show connecting icon other than level = 0 icon . 

Just add 'delete icon.dataset.connecting' if 'icon.dataset.connecting == true' in connected code.

Comment 6

5 years ago
Created attachment 736654 [details] [diff] [review]
patch for wifi icon display wrong
Attachment #736654 - Flags: review?(etienne)

Comment 7

5 years ago
But,some other issue should be solved too. That is why the connected wifi's
signal level equals 0. 

It seems that the wifi signalStrength has a mistake.
This issue always reproduce when restart the phone.

As I found the log follow:
The system app (statusbar) LOG:
I/Gecko   (  144): getConnectionInformation info.signalStrength = -96
I/Gecko   (  144): getConnectionInformation info.relSignalStrength = 8
E/GeckoConsole(  144): Content JS LOG at
app://system.gaiamobile.org/js/statusbar.js:499 in sb_updateWifi: 
relSignalStrength = 8
E/GeckoConsole(  144): Content JS LOG at
app://system.gaiamobile.org/js/statusbar.js:500 in sb_updateWifi: 
icon.dataset.level = 0

While the settings app LOG:
I/Gecko   (  145):  onscanresultsavailable network.ssid = Connectify-me
=== Number(match[3])[注:signalStrength] = -57 === signal = 95
I/Gecko   (  145): lxp:: onscanresultsavailable network.relSignalStrength = 95
E/GeckoConsole(  400): Content JS LOG at
app://settings.gaiamobile.org/js/wifi.js:333 in onScanSuccess: 
network.ssid = Connectify-me ===settings network.relSignalStrength = 95
(Assignee)

Comment 8

5 years ago
Comment on attachment 736654 [details] [diff] [review]
patch for wifi icon display wrong

Review of attachment 736654 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the lint issue fixed

::: apps/system/js/statusbar.js
@@ +491,4 @@
>          case 'connected':
>            icon.hidden = false;
>  
> +          if(icon.dataset.connecting) {

nit: missing a space before the |(|, this won't pass the linter.
Attachment #736654 - Flags: review?(etienne) → review+

Comment 9

5 years ago
Created attachment 736736 [details] [diff] [review]
patch for bug853756
Attachment #736736 - Flags: review?(etienne)
(Assignee)

Updated

5 years ago
Attachment #736654 - Attachment is obsolete: true
(Assignee)

Comment 10

5 years ago
Comment on attachment 736736 [details] [diff] [review]
patch for bug853756

Review of attachment 736736 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #736736 - Flags: review?(etienne) → review+
(Assignee)

Comment 11

5 years ago
https://github.com/mozilla-b2g/gaia/commit/bc54b1482e32245ec5d8ff1316c77b6c1d968dc6
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
blocking-b2g: --- → tef?

Updated

5 years ago
blocking-b2g: tef? → tef+

Updated

5 years ago
Assignee: nobody → etienne
Uplifted 853756 to:
v1-train: 3d3de3a9c12e48190a3e1f3c59a4e97f90678234
v1.0.1: 37b659535f9e8345e1a2adfc2d5871889ae66355
status-b2g18: --- → fixed
status-b2g18-v1.0.1: --- → fixed

Comment 13

5 years ago
Tested with:
Gecko: ea6a890
Gaia: b750757
QC RIL: V1.01.00.01.19.072
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.