Scrolling is blocked by page content

VERIFIED WORKSFORME

Status

()

Firefox
PDF Viewer
P4
normal
VERIFIED WORKSFORME
5 years ago
4 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

19 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-performance], URL)

(Reporter)

Description

5 years ago
Mozilla/5.0 (X11; Linux x86_64; rv:22.0) Gecko/20130314 Firefox/22.0 ID:20130314030914 CSet: b672877ed046

Opening the given PDF the scrolling stops when page 19 is reached. This applies to the keyboard, mouse, and touch events.

1. Open http://www.dr-feil.com/ebook/fettschlau-abnehmen.pdf
2. Scroll do page 19
3. Try to continue scrolling
FWIW, WFM on Win 7 x64 with 19 and Trunk (PDF.js 0.7.390).
(Reporter)

Comment 2

5 years ago
Got a Mac now and tested there. It's also working on that box. It still fails on Linux with the touchpad and the external mouse for the Lenovo X230 notebook.
OS: All → Linux
I tried on ubuntu and it it blocks for maybe a half a second for me, which is somewhat expected since it looks like it has some large images that have to be prescaled.
(Reporter)

Comment 4

5 years ago
For me it blocks forever until I hit the e.g. Windows or Alt keys. At this time all the events are getting handled. Looks like those are queued in some way.

Updated

5 years ago
Priority: -- → P4
Whiteboard: [pdfjs-c-performance]
I just tried in development versions of Firefox and pdf.js on my Ubuntu machine and it worked fine -- no pause on page 19 or any other page. One of the recent performance improvements has probably fixed it.

Thanks for the bug report.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

4 years ago
I can confirm that its no longer happening.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.