Page specific Greasemonkey JS not initiating Nightly 03-21 and 03-22

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: RlDreams, Unassigned)

Tracking

({addon-compat})

22 Branch
x86
Windows 8
addon-compat
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:22.0) Gecko/20130322 Firefox/22.0
Build ID: 20130322031028

Steps to reproduce:

Let update 22.0a1 install on 03-21 and 03-22


Actual results:

Page specific scripts not loading. Extensions show as enabled and show as active and loaded, but are not loading.


Expected results:

Script should have loaded
(Reporter)

Updated

5 years ago
Keywords: addon-compat

Comment 1

5 years ago
Provide a testcase or the add-on to test.
Flags: needinfo?(randy)
Keywords: testcase-wanted
(Reporter)

Comment 2

5 years ago
Sorry for my stupidity,but I'm having problems getting a debug. The 2 problems I have noticed are with Facebook Auto Poke 8.0.0 in Greasemokey When it initiates I get 
-->Log created. Defining support routines... loadSettings saveSettings deleteSettings escapeHtml padString formatDate Array.prototype.average ...done defining. Defining main structure... reboot pokeBack pokeUser goNow halt [Variables] reviveCounter setDocumentHead userControlPanelOpen functionsToStrings programState pokeAllFriendsCallback pokeAllFriends ArbiterResponder boot d_com ...done defining. Loading jQuery... jQuery loaded. Extending jQuery for JSON stringify... done. Checking local storage for stored settings... done. Autopoke bootloading... Env is undefined. Autopoke bootloading... Env is undefined. Autopoke bootloading... Env is undefined. Autopoke bootloading... Env is undefined. Autopoke bootloading... Env is undefined.

The other page specific script is http://ehibbert.org.uk/extension/install.html ,http://wiki.modplugin.org/index.php/Main_Page for Yahoo groups. I have already reported the issue to the author
Flags: needinfo?(randy)

Comment 3

5 years ago
If the issue is about scripts/add-ons, report it to their authors. Nightly APIs may change and some extensions are broken.
(Reporter)

Comment 4

5 years ago
As I stated in my prior comment I already reported the issue to the author before I posted the bug here.

Updated

5 years ago
Summary: Page specific JS not initiating Nightly 03-21 and 03-22 → Page specific Greasemonkey JS not initiating Nightly 03-21 and 03-22

Comment 5

5 years ago
RlDreams: Is this still a problem nowadays?
Flags: needinfo?(randy)
(Reporter)

Comment 6

5 years ago
No, no longer an issue,but then again now on 27.01a not 22  which was the version with the issue
Flags: needinfo?(randy)

Comment 7

5 years ago
Your STR are really not accurate, provide better STR step by step.
Flags: needinfo?(randy)
(Reporter)

Comment 8

5 years ago
Well since this was on a nightly release of 23 7 months ago ,it is a little difficult to recreate to get more details. I would say your first step would be to go back in time ,since we are now working with FF 27 and 24 is the current public release .
Flags: needinfo?(randy)
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.