Logging in sometimes generates 500

RESOLVED DUPLICATE of bug 864822

Status

Mozilla Reps
reps.mozilla.org
RESOLVED DUPLICATE of bug 864822
5 years ago
5 years ago

People

(Reporter: bensternthal, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
If i log into stage with bsternthal@mozilla.org I get a 500 error.

This does not occur with my bugzilla email booboobenny+bugzilla@gmail.com

This should generate a traceback you can look at for more info.
Traceback from another user on prod.


Traceback (most recent call last):

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/views/decorators/cache.py", line 89, in _wrapped_view_func
    response = view_func(request, *args, **kwargs)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/views/decorators/http.py", line 41, in inner
    return func(request, *args, **kwargs)

  File "/data/www/reps.mozilla.org/remo/remo/base/views.py", line 55, in mozilla_browserid_verify
    email=data['email'])

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/contrib/auth/models.py", line 160, in create_user
    user.save(using=self._db)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/db/models/base.py", line 463, in save
    self.save_base(using=using, force_insert=force_insert, force_update=force_update)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/db/models/base.py", line 551, in save_base
    result = manager._insert([self], fields=fields, return_id=update_pk, using=using, raw=raw)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/db/models/manager.py", line 203, in _insert
    return insert_query(self.model, objs, fields, **kwargs)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/db/models/query.py", line 1593, in insert_query
    return query.get_compiler(using=using).execute_sql(return_id)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/db/models/sql/compiler.py", line 912, in execute_sql
    cursor.execute(sql, params)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/db/backends/mysql/base.py", line 114, in execute
    return self.cursor.execute(query, args)

  File "/usr/lib64/python2.6/site-packages/MySQLdb/cursors.py", line 173, in execute
    self.errorhandler(self, exc, value)

  File "/usr/lib64/python2.6/site-packages/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue

IntegrityError: (1062, "Duplicate entry 'fXDnVWiSvCOc8YaENDd9ZSz0cZQ' for key 'username'")
Summary: Logging into stage with specific account generates 500 → Logging in sometimes generates 500
Depends on: 864822
This bug should be resolved by the fix applied to bug 864822.
Closing this bug as duplicate. If the error persists this bug should be reopened.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 864822
You need to log in before you can comment on or make changes to this bug.