JSFunctionCallback is not called when native functions are called

RESOLVED DUPLICATE of bug 651599

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 651599
5 years ago
5 years ago

People

(Reporter: Robin Ehrlich, Unassigned)

Tracking

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 728305 [details]
functionCallback.diffs

User Agent: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.2)

Steps to reproduce:

This is a second post of bug 651599. I am providing code that can be applied against mozjs17.

It is important for a debugger to be notified when a native function is called. This callback is not currently supported.


Actual results:

native functions are not traced. In order for the trace to be effective a few new arguments need to be added to the callback so that the callback function can determine the pc, arguments and function being called.

The attached diff file provides a suggested implementation.


Expected results:

native functions should be traced.

Comment 1

5 years ago
Could you please post a unified diff, of the sort produced by 'diff -u'? That is much easier to read, and we have tools for reviewing such patches comfortably.
Please don't open new bugs for something you know is already on file in another bug. Just comment on that bug. (Not trying to be complicated or to make your life harder, here. It's just almost impossible to sanely work with bugs if important information is scattered across several of them.)

Also, if you want the patch to be applied to SpiderMonkey, please check out the instructions here:
https://developer.mozilla.org/en-US/docs/Developer_Guide/How_to_Submit_a_Patch

I'll mark this bug as a duplicate, so please attach a new version to the original one.

ps: I see jimb already addressed the last part, but the guide gives more information on how to format a patch.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 651599
You need to log in before you can comment on or make changes to this bug.