italyonmarket.com - javascript: bad image positioning

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Italian
P4
normal
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: mavog, Unassigned)

Tracking

Details

(Whiteboard: [LAYER][havefix][havecontact], URL)

(Reporter)

Description

17 years ago
Maybe relating to bug # 85311? The 2 images "Business" and "...e altro" on this
page aren't placed correctly. This issue was also present in NS 6-6.01
(Reporter)

Comment 1

17 years ago
The 1st time you load the page OnMouseOver on the central image should make
appear these 2 gif's.

Comment 2

17 years ago
Mozilla doesn't support <layer>s

Comment 3

17 years ago
Yep mozilla will never support layers, which were a Netscape 4 proprietary thing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: Layer-javascript: bad image positioning → [Layer] javascript: bad image positioning
(Reporter)

Comment 4

17 years ago
OK, but as far as I know layers are widely used on the web (probably also thanks
to good IE support). Sorry if I posted an useless message.

Updated

17 years ago
Priority: -- → P4

Comment 5

17 years ago
-> Intl
Assignee: bclary → nitot
QA Contact: zach → momoi

Updated

17 years ago
Component: Evangelism → European
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 6

17 years ago
Moving to new component "West Europe".  European component is being removed. 
See bug 95808 for details.
Component: European → West Europe
QA Contact: momoi → caillon
Summary: [Layer] javascript: bad image positioning → italyonmarket.com - javascript: bad image positioning
Whiteboard: [LAYER]
havefix:
first they need to sniff better, and send the IE version of their page, which
use divs instead of layers to every gecko based browser.
then they need to replace the two MM_blabla() function, which are old
dreamweaver generated functions that will not work properly with gecko. (non dom
aware functions)
Whiteboard: [LAYER] → [LAYER][havefix]
corrected versions of the two dreamweaver functions :

function MM_showHideLayers() {
  var i,p,v,obj,args=MM_showHideLayers.arguments;
  for (i=0; i<(args.length-2); i+=3) if ((obj=MM_findObj(args[i]))!=null) {
v=args[i+2];
    if (obj.style) { obj=obj.style;
v=(v=='show')?'visible':(v=='hide')?'hidden':v; }
    obj.visibility=v; }
}


function MM_findObj(n, d) {
  var p,i,x;  if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {
    d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
  if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++)
x=d.forms[i][n];
  for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=MM_findObj(n,d.layers[i].document);
  if(!x && d.getElementById) x=d.getElementById(n); return x;
}

contact info seems to be tech@italyonmarket.com .
Whiteboard: [LAYER][havefix] → [LAYER][havefix][havecontact]
can someone contact them with the fix ?
moving to the new Italian component.
Assignee: nitot → italian
Component: Europe: West → Italian
QA Contact: z-caillon-obsolete2 → italian
domain gone
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.