Closed Bug 854019 Opened 7 years ago Closed 7 years ago

in-content XBL bindings don't work right in remote XUL domains

Categories

(Core :: XBL, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla22
Tracking Status
firefox21 + fixed

People

(Reporter: bholley, Assigned: bholley)

References

Details

(Keywords: regression, Whiteboard: [leave uplift for bholley])

Attachments

(1 file)

Bug 853747 revealed that our remote XUL hackery in bug 844783 breaks video controls. I'm investigating.
So the issue here is a permutation of a pretty familiar problem.

When XBL scopes are disabled by remote XUL, we run XBL directly in the content compartment, except in automation. In this case, that broke video controls, because the NAC gets wrapped in a SOW, and the video controls can't access it anymore due to nsContentUtils::IsCallerXBL() not returning the right thing.

I'm attaching a patch. But more generally, I'm worried that our in-content XBL controls will start to subtle depend on the existence of the compartment boundary, which we won't notice until we ship a release and somebody tries to use the associated element on a XUL-whitelisted domain.

Jaws, dao, and dolske - can you guys keep that in mind when doing future reviews?
This is a regression from bug 844783, so we'll want to uplift both together.
Comment on attachment 728594 [details] [diff] [review]
Continue checking the XBL bit if remote XUL disables XBL scopes. v1

Please document the new methods (especially the overall setup they're meant to enforce) and the difference between the two boolean members, and r=me
Attachment #728594 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/7ae2b31a7587
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
Assignee: nobody → bobbyholley+bmo
Comment on attachment 728594 [details] [diff] [review]
Continue checking the XBL bit if remote XUL disables XBL scopes. v1

See bug 844783 comment 53.
Attachment #728594 - Flags: approval-mozilla-aurora?
Whiteboard: [leave uplift for bholley]
Attachment #728594 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.