Select dropdown off by two when transform applied to container.

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: chris, Unassigned)

Tracking

19 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.172 Safari/537.22

Steps to reproduce:

Select box created within a div with transform: rotate(0deg) scale(1, 1); set.  Select third element in select drop-down.


Actual results:

First element chosen as selected item.


Expected results:

Third element chosen as selected item.
Please provide a testcase, either as attachment or as public URL.
Flags: needinfo?(chris)
(Reporter)

Comment 2

5 years ago
Created attachment 729213 [details]
Demonstration of bug.
Flags: needinfo?(chris)
Attachment #729213 - Attachment mime type: text/plain → text/html
Your testcase works for me with Firefox trunk on Windows7 and OSX and Firefox19.0.2 on Windows7.

Do you do something special to select the third element ?
(Reporter)

Comment 4

5 years ago
Firefox 19.0.2 on Mac OS X, confirmed on three devices.  Worked fine on versions 16, 18.
Could you please test this with a nightly build: http://nightly.mozilla.org/ ?
(Reporter)

Comment 6

5 years ago
Looks like it's been fixed.  Lovely... Do you still backport, or not bother?
I think it's already to late for backporting it to FF20 but it would be still possible for FF21 if it's not already fixed there.

I would invest time to find the bug that fixed it if this would be a major issue for a major site but it doesn't seem to be the case here (correct me if I'm wrong).

I will mark this bug report worksforme because it works in the latest nightly. 
Thank you for the bug report and for testing a nightly build !
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.