[Buri][STK]The display text screen will not shown when switching on

RESOLVED DUPLICATE of bug 854738

Status

P1
normal
RESOLVED DUPLICATE of bug 854738
6 years ago
5 years ago

People

(Reporter: sync-1, Assigned: frsela)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:-, b2g18+)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
+++ This bug was initially created as a clone of Bug #428202 +++
 
 Created an attachment (id=372675)
 screen shot1
 
 DEFECT DESCRIPTION:
 (1)Switch on the mobile with one SIM card, which has popup welcome screen.
 (2)But it will not show the popup display text.----NOK, it will only show the SATK menu. see screenshot1
 
 REPRODUCING PROCEDURES:
 
 EXPECTED BEHAVIOUR:
 It should only show the popup screen.(see screenshot2, got from old version)
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 big
 
 REPRODUCING RATE:
 100%
 
 For FT PR, Please list reference mobile's behavior:
 
 AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.044
 Firefox os  v1.0.1
 Mozilla build ID: 20130319070203
 
 ++++++++++ end of initial bug #428202 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
 DEFECT DESCRIPTION:
 
 REPRODUCING PROCEDURES:
 
 EXPECTED BEHAVIOUR:
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 
 For FT PR, Please list reference mobile's behavior:

Updated

6 years ago
blocking-b2g: --- → tef?
Priority: P2 → P1

Comment 1

6 years ago
Please attach the screenshot.  Nothing like this reproduces on Unagi, currently on 3/25 nightly.

Updated

6 years ago
Flags: needinfo?(sync-1)

Comment 2

6 years ago
Posted image Screenshot1

Comment 3

6 years ago
Posted image Screenshot2
This is the screen wanted.
Flags: needinfo?(sync-1)
partner suspect that this is related to Bug 849698. and partner stated that it used to work earlier. 

triage: tef-. it does not impact tef release markets
Assignee: nobody → frsela
blocking-b2g: tef? → -
tracking-b2g18: --- → +
Keywords: regression
If I understood well, this is the same as https://bugzilla.mozilla.org/show_bug.cgi?id=849698#c15

This little change can fix this race-condition: https://github.com/mozilla-b2g/gaia/pull/8793/files#L1L23

If patch https://github.com/mozilla-b2g/gaia/pull/8793/files#L1L23 is landed, (bug https://bugzilla.mozilla.org/show_bug.cgi?id=847040) will include this fix.
Status: NEW → UNCONFIRMED
Ever confirmed: false
See Also: → bug 849698
Also, more info: https://bugzilla.mozilla.org/show_bug.cgi?id=854738#c1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 854738
Ignore references to 849698, I mean 854738.
Sorry for the noise
See Also: bug 849698
(Reporter)

Comment 8

6 years ago
(In reply to comment #6)
 > Comment from Mozilla:If I understood well, this is the same as
 > https://bugzilla.mozilla.org/show_bug.cgi?id=849698#c15
 > 
 > This little change can fix this race-condition:
 > https://github.com/mozilla-b2g/gaia/pull/8793/files#L1L23
 > 
 > If patch https://github.com/mozilla-b2g/gaia/pull/8793/files#L1L23 is landed,
 > (bug https://bugzilla.mozilla.org/show_bug.cgi?id=847040) will include this
 > fix.
 >
 
 
 the v1.0.1 has not add this patch. 
 With this patch, this bug can be fixed;
(In reply to sync-1 from comment #8)

>  the v1.0.1 has not add this patch. 

Is under review (r?) just now

>  With this patch, this bug can be fixed;

Did you test it? Nice to confirm it fix the bug :)
(Reporter)

Comment 10

6 years ago
(In reply to comment #10)
 > Comment from Mozilla:(In reply to sync-1 from comment #8)
 > 
 > >  the v1.0.1 has not add this patch. 
 > 
 > Is under review (r?) just now
 > 
 > >  With this patch, this bug can be fixed;
 > 
 > Did you test it? Nice to confirm it fix the bug :)
 > 
 
 I dont
(Reporter)

Comment 11

6 years ago
(In reply to comment #11)
 > (In reply to comment #10)
 > > Comment from Mozilla:(In reply to sync-1 from comment #8)
 > > 
 > > >  the v1.0.1 has not add this patch. 
 > > 
 > > Is under review (r?) just now
 > > 
 > > >  With this patch, this bug can be fixed;
 > > 
 > > Did you test it? Nice to confirm it fix the bug :)
 > > 
 > 
 > I dont

Comment 12

6 years ago
(In reply to sync-1 from comment #11)
> (In reply to comment #11)
>  > (In reply to comment #10)
>  > > Comment from Mozilla:(In reply to sync-1 from comment #8)
>  > > 
>  > > >  the v1.0.1 has not add this patch. 
>  > > 
>  > > Is under review (r?) just now
>  > > 
>  > > >  With this patch, this bug can be fixed;
>  > > 
>  > > Did you test it? Nice to confirm it fix the bug :)
>  > > 
>  > 
>  > I dont

Has the patch been landed???
(In reply to buri.blff from comment #12)
> (In reply to sync-1 from comment #11)
> > (In reply to comment #11)
> >  > (In reply to comment #10)
> >  > > Comment from Mozilla:(In reply to sync-1 from comment #8)
> >  > > 
> >  > > >  the v1.0.1 has not add this patch. 
> >  > > 
> >  > > Is under review (r?) just now
> >  > > 
> >  > > >  With this patch, this bug can be fixed;
> >  > > 
> >  > > Did you test it? Nice to confirm it fix the bug :)
> >  > > 
> >  > 
> >  > I dont
> 
> Has the patch been landed???

Here:
https://github.com/mozilla-b2g/gaia/commit/20db54aa11b5ab00102c58e97690b57f7cd8b5f3

and here:
https://github.com/mozilla-b2g/gaia/commit/5845f5aa1c67ec37ebfe12a8b15ab9cf43be3007
You need to log in before you can comment on or make changes to this bug.