Spaces not inserted between words when using gesture typing in address bar

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: openjck, Unassigned)

Tracking

({ux-consistency})

22 Branch
ARM
Android
ux-consistency
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130227231415

Steps to reproduce:

1. Be sure you are using Android 4.2 or higher
2. Open Firefox Nightly
3. Tap the address bar
4. Use Android gesture typing to enter a word
5. Without hitting the space bar, use Android gesture typing to enter another word


Actual results:

The two words appear right next to each other. A space is not automatically added between them.


Expected results:

After the second word is entered, a space should automatically be added between the two words. This happens in other Android applications (like the Messaging application) and even in input fields rendered by Firefox (like the Google search bar).
(Reporter)

Updated

6 years ago
Keywords: ux-consistency
OS: All → Android
Hardware: All → ARM
(Reporter)

Updated

6 years ago
Version: Firefox 19 → Firefox 22
Which Android device, version and keyboard are you using?
(Reporter)

Comment 2

6 years ago
Samsung Galaxy Nexus, Android 4.2.2, stock keyboard. See the following about gesture typing.

http://support.google.com/nexus/bin/answer.py?hl=en&answer=2811346
We had code to trick Swype into inserting spaces between words, but we didn't have a special case for Android's gesture typing keyboard because it didn't exist at the time. :) But even the Swype spacing is broken now.
Hey John, because of a limitation in Android, for dual-purpose inputs like the address bar, we have to either choose a URL mode or a text mode.

In URL mode, spaces are not inserted automatically, but you get keys like '/' and '.com' on certain keyboards.

In text mode, spaces are inserted automatically, but you don't get those keys.

As a trade off, currently we are defaulting to URL mode, but when you enter a space manually, we switch to text mode, and future words should have automatic spaces.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.