Closed Bug 854435 Opened 7 years ago Closed 6 years ago

Web Console Can Log Events Out of Order

Categories

(DevTools :: Console, defect)

19 Branch
x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 755555

People

(Reporter: nik9000, Unassigned)

Details

(Keywords: testcase)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307122351

Steps to reproduce:

I added a log to my form validation code to make sure it was firing.
I turned on both Net and JS logging.
I submitted the form while invalid.
I submitted the form while valid.

Firefox version: 19.0.2


Actual results:

The form submission log line appeared above the form validation log line, leading me to believe that the validation wasn't firing at all.  It looked like this:

[11:25:10.718] validating
[11:25:14.744] POST https://localhost/foo [HTTP/1.1 200 OK 18ms]
[11:25:14.548] validating


Expected results:

The form submission log line should have appeared below the form validation log line.  Like this:

[11:25:10.718] validating
[11:25:14.548] validating
[11:25:14.744] POST https://localhost/foo [HTTP/1.1 200 OK 18ms]
Attachment #729002 - Attachment mime type: text/plain → text/html
Keywords: testcase
I am seeing the same behaviour in 26.0
Component: Untriaged → Developer Tools: Console
Thanks for the bug report and triage.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 755555
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.