Feedback app icon location different after |make reset-gaia|

RESOLVED FIXED

Status

Firefox OS
GonkIntegration
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: zac, Assigned: fabrice)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
STR:
1. Flash with a b2g18/v1-train PVT engineering build
2. Note the location of the Feedback icon in the bottom toolbar.
3. Perform |make reset-gaia| using the v1-train from gaia repo.
4. The location of the Feedback icon changes Bto in the homescreen grid area.

Tested with:
Build ID: 20130324230203
Gaia commit: 5a31a56b96 (v1-train)

Expected behaviour:
Same location regardless of profile.
The two versions of Gaia profiles should share the same defaults.
(Assignee)

Comment 1

5 years ago
Julien, I think this is related to the recent changes you made to the Makefile.
Flags: needinfo?(felash)
This is related but the cause is not the changes I made.

Since the 13th March the pvt builds are done using DOGFOOD=1. This env variable causes the feedback app to be put in the bottom launcher (file build/applications-data.js, line 133, and Makefile line 82).

|make reset-gaia| without any env variable should _not_ push the feedback app at all, so this is strange that you get it. Maybe you have a directory "feedback" lying in your apps/ directory, that should not be there. It might be here because it used to be here, and when we removed it, some generated files made the directory stay. So Zac this might be the cause, could you check ?
Flags: needinfo?(felash)
If we need this to be consistent for after reinstalling Gaia is it just necessary for us to specify DOGFOOD=1? Where can we find the full command line / environment variables set for generating the pvtbuilds so we can compare?
I added DOGFOOD=1 to http://qa-selenium.mv.mozilla.com:8080/job/b2g.unagi.gaia.v1-train.ui/387/consoleFull, and that didn't get us back to our usual crop of test apps.

But, yes, according to that same job, we're definitely pushing the feedback app:

[optimize] aggregating javascript for : "feedback"
<snip>
push: profile/webapps/feedback.gaiamobile.org/application.zip -> /system/b2g/webapps/feedback.gaiamobile.org/application.zip

...and now I see the Feedback app in the bottom row of core apps; but should it be there at all?  (comment 2).
I filed Bug 854444 this morning - I couldn't find any bug that renabled the Feedback icon in the current builds, so I assuming that it is not supposed to be there.

(In reply to Stephen Donner [:stephend] from comment #5)
[snip]
> 
> ...and now I see the Feedback app in the bottom row of core apps; but should
> it be there at all?  (comment 2).
As I commented in Bug 854444, I wonder if PRODUCTION=1 was not wanted instead of DOGFOOD=1.
> I added DOGFOOD=1 to http://qa-selenium.mv.mozilla.com:8080/job/b2g.unagi.gaia.v1-train.ui/387/consoleFull, and that didn't get us back to our usual crop of test apps.

My hesitation in adding DOGFOOD=1 to the Gaia UI test builds was because I'm not entirely sure this is what we want. What are the differences this introduces? What differences does PRODUCTION=1 introduce?
PRODUCTION selects only the actual apps. (without PRODUCTION we are in dev mode, and we flash all our test apps)

DOGFOOD is PRODUCTION plus the feedback app.
So DOGFOOD=1 was added for all builds because that's what controls that the prefs for the supl (a-gps) servers are used. Then Bug 851281 made |DOGFOOD=1| behave like |make dogfood| because otherwise v1.0.1 builds were borked. But as a result it made all apps but production apps + feedback disappear in all builds.

I'll see how to change how the supl prefs are added, and then change the build configurations, which should fix this.
Depends on: 855673
Could you please now check the new builds are correct ?
fixed in Bug 855673
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.