ui-bg_highlight-soft_100_eeeeee_1x100.png is a 404

VERIFIED FIXED

Status

Input Graveyard
Dashboard
VERIFIED FIXED
5 years ago
a year ago

People

(Reporter: stephend, Assigned: willkg)

Tracking

Details

(Whiteboard: u=dev c=general p=1 s=input.2014q4 , URL)

WebPagetest.org [1] reports a 404 requesting an image:

Request 14:

URL: https://input.allizom.org/static/css/images/ui-bg_highlight-soft_100_eeeeee_1x100.png
Host: input.allizom.org
Error/Status Code: 404
Initiated By: https://input.allizom.org/static/js/dashboard-min.js?build=7828d1d line 2 column 75542
Start Offset: 4.081 s
Time to First Byte: 108 ms
Bytes In (downloaded): 0.5 KB
Bytes Out (uploaded): 0.7 KB

Request Headers:

GET /static/css/images/ui-bg_highlight-soft_100_eeeeee_1x100.png HTTP/1.1
Host: input.allizom.org
Connection: keep-alive
User-Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.172 Safari/537.22
Accept: */*
Referer: https://input.allizom.org/en-US/?date_start=2012-12-25&selected=90d&platform=FirefoxOS
Accept-Encoding: gzip,deflate,sdch
Accept-Language: en-US,en;q=0.8
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.3
Cookie: anoncsrf=nsBTCSZFdB6uUJoqxNVMOuyT0VLECbYf; __utma=205910987.929625683.1364232828.1364232828.1364232828.1; __utmb=205910987.1.10.1364232828; __utmc=205910987; __utmz=205910987.1364232828.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)

Response Headers:

HTTP/1.1 404 Not Found
Date: Mon, 25 Mar 2013 17:33:48 GMT
Server: Apache
X-Backend-Server: input1.stage.webapp.phx1.mozilla.com
Content-Length: 257
Keep-Alive: timeout=5, max=999
Connection: Keep-Alive
Content-Type: text/html; charset=iso-8859-1

[1] http://www.webpagetest.org/result/130325_SH_VJ8/1/details/#request14
I think that's from jquery, but I'm not seeing it kick up a 404 in the console. I'll have to look at what webpagetest is doing. Maybe it's reading through the js code and noticing it's not there, but that js code isn't ever executed or something like that.
(BTW, should've mentioned I don't see it either, with Firefox (stable nor nightly); neither does WebPagetest -- so must be a WebKit-specific call in jQuery?

http://www.webpagetest.org/result/130325_YK_WH3/
Putting these in my queue for this quarter.
Assignee: nobody → willkg
Whiteboard: u=dev c=general p= s=input.2013q2
The action item for this bug is to figure out whether webpagetest is just cruising all the urls in the .js scripts and noticed this one kicks up a 404 or whether webpagetest is triggering some part of the site that is actually in use and this is a real issue.

In the case of the former, we can write an explanation in the comments and close it out.

In the case of the latter, it'd be great to get steps to reproduce and fix it.

Marking this as a mentored bug. If you're interested in working on it, comment here or ping willkg in #input on irc.mozilla.org.
Whiteboard: u=dev c=general p= s=input.2013q2 → u=dev c=general p= s=input.2013q2 [mentor=willkg]
I don't think it's just ui-bg_highlight-soft_100_eeeeee_1x100.png that returns 404 but also:
https://input.mozilla.org/static/css/images/ui-bg_gloss-wave_35_f6a828_500x100.png
https://input.mozilla.org/static/css/images/ui-icons_ffffff_256x240.png
...

To reproduce, open "developer tools->web console", refresh the dashboard page and then click on the date to active date-picker.

This are all ui-lightness images and I think the problem lies in the wrong urls in static/css/dashboard-min.css. I guess someone copied the css from static/css/ui-lightness/jquery-ui.css but forgot to change the urls to also include "ui-lightness" in the url path.

Today I have forked the https://github.com/mozilla/fjord and all images are found, I suppose because static/css/ui-lightness/jquery-ui.css is included in the dashboard instead of static/css/dashboard-min.css.

All the missing images can be found here:
https://input.mozilla.org/static/css/ui-lightness/images/ui-bg_highlight-soft_100_eeeeee_1x100.png
https://input.mozilla.org/static/css/ui-lightness/images/ui-bg_gloss-wave_35_f6a828_500x100.png
https://input.mozilla.org/static/css/ui-lightness/images/ui-icons_ffffff_256x240.png
...

Regards
Senicar
Whiteboard: u=dev c=general p= s=input.2013q2 [mentor=willkg] → u=dev c=general p= s=input.2013q3 [mentor=willkg]
2013q3 is over. I don't think this is critical, so I'm not putting it in the 2013q4 sprint. It'll happen when it happens.
Whiteboard: u=dev c=general p= s=input.2013q3 [mentor=willkg] → u=dev c=general p= s= [mentor=willkg]
This shouldn't have been assigned to me.
Assignee: willkg → nobody
Mentor: willkg
Whiteboard: u=dev c=general p= s= [mentor=willkg] → u=dev c=general p= s=
Given that this is pretty old, I verified it's still true.

Then I actually looked into it. Senicar's analysis is right on. What's going on is that when we minify all the dashboard css files into dashboard.css, the relative urls ui-lightness/jquery-ui.css has end up pointing somewhere else. So I moved things around on the file system so they work both directly (in a development environment) as well as when minified (in dashboard.css). Pretty sure that should fix it.

In a PR: https://github.com/mozilla/fjord/pull/365
Assignee: nobody → willkg
Mentor: willkg
Status: NEW → ASSIGNED
Whiteboard: u=dev c=general p= s= → u=dev c=general p=1 s=input.2014q4
Pushed to prod just now.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Thanks, Will -- verified here on staging (http://www.webpagetest.org/result/141013_8J_YE9/1/details/) and in prod.
Status: RESOLVED → VERIFIED
Awesome! 

I had it on my list of things to do, but then the dog ate the list and then I was like, "oh noes! what am i to do!" (I always think to myself in all lowercase.) Then I promptly forgot and went off to do other things.

Thank you for verifying this!
Product: Input → Input Graveyard
You need to log in before you can comment on or make changes to this bug.