deleting profile that was created with -createprofile option does not remove all files

VERIFIED INVALID

Status

Core Graveyard
Profile: BackEnd
VERIFIED INVALID
17 years ago
2 years ago

People

(Reporter: Grace Bush, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
steps to reproduce:
seen on both branch and trunk (win and linux so far)
1. ./netscape -createprofile foo (netscp6 -createprofile foo)
2. launch and test
3. run profile manager and choose to delete foo

actual results:  after creation ./mozilla/foo/foo/44533.slt is created on linux
                             c:\winnt\~~~\profiles\foo\foo\3234.slt is created 
                              on windows
   after deletion the directories /foo/44533.slt (\foo\3234.slt) are removed
leaving the topmost foo directory in place.
(Assignee)

Comment 1

17 years ago
This is not a new bug. It is not a problem with profile deletion but of profile
creation. See bug 56587. See how it's creating ./mozilla/foo/foo/44533.slt. The
extra foo is causing the problem. Bug 56587 is reviewed and awaiting sr. Because
the problem is creation and not deletion and because this will be fixed shortly
by that, marking invalid.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

17 years ago
a reminder to review old bugs!
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.