[B2G][Homescreen] Moving ICONs results in overlapping and sticking in random places.

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: sshipley, Assigned: crdlc)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

(Whiteboard: smoketest)

Attachments

(5 attachments)

(Reporter)

Description

6 years ago
Created attachment 729261 [details]
Screenshot of ICONS sticking and overlapping

Description:
When trying to customize ICON layout on the Unagi device, moving many ICONs rapidly to various positions, on the homescreen and in the dock, result in some ICONs sticking in places that over lap other ICONs or in a state where they can be moved around freely and do not function as intended. 

Repro Steps:
1) Updated to Unagi Build ID: 20130325070203
2) Unlock phone
3) Long press an ICON and move it to another location
4) Long press same ICON and move it again to a different location
5) Repeat steps 3 and 4 with at least 4 or more different ICONs
6) Long press all but two ICONs in the phone dock and move them out of the dock
7) With two ICONS remaining in the dock, return 3 or more to the dock dropping     them in various places and on top of other icons in the dock
8) Repeat steps 7 and 8 at least 2 or more times.
 
Actual:
ICONs stick and over lap in various places on the Unagi device, these ICONs will duplicate leaving the original in the stuck position and the duplicate where it would have been dropped if the issue hadn't happened. Sometimes duplicates are relocatable and will move from page to page with the users interaction, this leaves the possibility of ICON being anywhere on the home screen including "Everything Me" and the homepage where the digital time is displayed.  

Expected:
ICONs will respond per the use case and set into the location where dropped by the user.

Environmental  Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/dec694d585e1
Gaia: 5a31a56b96a8fc559232d35dabf20411b9c2ca1d

Notes:
Repro frequency: %100 on 2 devices
Test Suite Name: Homescreen
See attached screenshots for more info.
Restarting the phone will erase all duplicated and stuck ICONs on the device.
(Reporter)

Comment 1

6 years ago
Created attachment 729262 [details]
ICON sticking in the middle of the clock
(Reporter)

Comment 2

6 years ago
Created attachment 729263 [details]
ICONs misplaced in the dock and the homescreen
(Reporter)

Comment 3

6 years ago
Created attachment 729264 [details]
ICON stuck on the "Everything Me" screen
(Reporter)

Updated

6 years ago
Keywords: regression
(Assignee)

Updated

6 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 4

6 years ago
Please could you explain a bit more the step 6? Thanks
(Assignee)

Comment 5

6 years ago
OK, I could see the problem, thanks
(Assignee)

Comment 6

6 years ago
Created attachment 729440 [details]
Patch v1

The problem was only reproducible in the dock. With the 7 and 8 steps is enough to reproduce the bug. For some reason, inserting a node re-triggers the blob URI to be validated and we revoked the url before insertBefore operation. Now, the revoked URL is the previous one and not the current. The fix is very simple
Attachment #729440 - Flags: review?(felash)
Attachment #729440 - Flags: feedback?(sshipley)
(Assignee)

Comment 7

6 years ago
The bug is reproducible on master and v1-train
blocking-b2g: --- → leo?
I've put some questions on github.

This seems to be simple but I never like adding some code to work around something we don't understand, so I'd really want that understand why and where the blob URI is revalidated.
(Assignee)

Comment 9

6 years ago
thanks, I replied you on github
Comment on attachment 729440 [details]
Patch v1

r=me

thanks for the good work !
Attachment #729440 - Flags: review?(felash) → review+
Comment on attachment 729440 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 846218
User impact if declined: the icons are behaving strangely when we move it out of the dock, requiring a reboot to make it appear correct again
Testing completed: yes
Risk to taking this patch (and alternatives if risky): low, small changes
String or UUID changes made by this patch: none
Attachment #729440 - Flags: approval-gaia-v1?(21)
(Assignee)

Comment 12

6 years ago
https://github.com/mozilla-b2g/gaia/commit/7d36796fcd49eed018139b76257f6b039fa24ba5
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Based upon the STR being particularly complicated, marking as blocking-b2g:-, but approving for v1.1 given the low risk evaluation.
blocking-b2g: leo? → -
tracking-b2g18: --- → +
Attachment #729440 - Flags: approval-gaia-v1?(21) → approval-gaia-v1+
Alex, the STR is actually not so complicated, merely moving icons out of the dock is enough to trigger the bug.
Uplifted commit 7d36796fcd49eed018139b76257f6b039fa24ba5 as:
v1-train: 85737fedceb457df195b129d216d1074cdcdba76
status-b2g18: --- → fixed

Comment 16

6 years ago
Issue no longer reproduces on v101, Mozilla RIL, and Commercial RIL:
Unagi Build ID: 20130329070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/5cc5df16447a
Gaia: 26b463f14caa11e0fc64fda09a17054da4bea68b

Verified as resolved on 3/29 Commercial RIL
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.