[br] Translate .lang file for Firefox Health Report (about:healthreport)

RESOLVED FIXED

Status

Mozilla Localizations
br / Breton
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: pascalc, Assigned: Michel Nédélec)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
We have the opportunity to release a new feature in Firefox, a self-auditing system giving advanced users useful information and tips about the performance of their browser. These users can also share this data with Mozilla so as to help improve Firefox performance. This new feature takes the form of a new in-product page accessible at about:healthreport

The product part of it are a few strings in the Firefox source code, the server-side part is a lang file to translate the UI, explain what the collected values are and give performance tips.

The repository for your locale is:
https://svn.mozilla.org/projects/l10n-misc/trunk/firefoxhealthreport/locale/br/

The specific file to translate is:
https://svn.mozilla.org/projects/l10n-misc/trunk/firefoxhealthreport/locale/br/fhr.lang

There is a staging server being set up there:
http://fhr-dev.allizom.org/br/

(Note at the time of filing this bug, the staging server is not autoupdating code and translations yet and is in heavy works since localizers are working in parallel to the webdev team creating this mini-site).

We might release this feature for the next Aurora but that's totally unsure, given that this is server side, we should be able to update the server after we have released the next Firefox Aurora. 

Thanks
(Reporter)

Updated

5 years ago
Assignee: nobody → mnedeleg
(Assignee)

Comment 1

5 years ago
Created attachment 742843 [details]
Firefox Health Report screenshot

I have localized the fhr.lang file and made some tests by changing the datareporting.healthreport.about.reportUrl parameter.

On the screenshot, you can see a problem with the text alignment for the number of number of bookmarks on the "Vital stats" part.
Another problem : the legend "Time in seconds" for the graphic is displayed on the numbers of the Y axis.
And I haven't been able to see Glossary page because the "Glossary" link seems broken (nothing happen when I click on it)

Could you dosomething to correct this ?
(Reporter)

Comment 2

5 years ago
The broken link for Glossary is a regression, I'll file a bug about it. Same for Time in seconds, although I think we may change soon of graphing library and that may solve this bug.

I'll also file a bug about the alignment problem, we should be able to fix that with CSS.
(Assignee)

Comment 3

3 years ago
This bug has been fixed long time ago so I close it
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.