STK proactive command popup does not always get displayed

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: cyang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 729327 [details]
STKUI debug trace

This seems like a regression.

The popup for some STK commands, i.e. DISPLAY_TEXT, PLAY_TONE, SET_UP_CALL, does not always get displayed. When the PDU is sent without menu selection, i.e. sent by System Simulator from GCF tests, the proper JSON string is sent up but no popup is displayed (only an empty SIM Toolkit menu shows). Note that the same PDU will show the popup if it is from a menu selection, i.e. select a menu item from SIM Toolkit menu which sends a SET_UP_CALL proactive command. Note also that if a second PDU was sent by the System Simulator, the popup does display.

Given the current behavior, perhaps this has something to do with the popup not showing unless the SIM Toolkit menu has been displayed at least once?

Example PDU for SET_UP_CALL: D01D81030110028202818385074F6E20686F6C648609911032042143651C2C

Attached are logs for when the above PDU is sent by the System Simulator.
I show this issue yesterday and I added a hack in other patch: https://github.com/mozilla-b2g/gaia/pull/8793/files#L1L23

If this patch is landed, this can be solved. Not sure if this is the more elegant way to fix this, but is a fast hack ;)

The case is a race condition, Now, async stk commands are delayed half a second, but in some case the main menu arrives later so refresh the screen with the main menu and removes the previous one.

I solved that increasing the async command delay in a second.

As you can see in the log, first we receive the async command:

2450:01-06 04:03:45.249   444   444 E GeckoConsole: Content JS LOG at app://settings.gaiamobile.org/js/utils.js:20 in debug: [DEBUG # Settings] ICC command to execute: {"commandNumber":1,"typeOfCommand":16,"commandQualifier":2,"options":{"confirmMessage":"On hold","address":"012340123456,1,2"}}

and later, the main menu is repainted:

2555:01-06 04:03:45.939   444   444 E GeckoConsole: Content JS LOG at app://settings.gaiamobile.org/js/utils.js:20 in debug: [DEBUG # Settings] Showing STK main menu
(Reporter)

Comment 2

5 years ago
Hi Fernando, thanks for the quick response! This hack does seem to have solved the issue. I am curious though, why was the main menu shown in the first place? In this particular case, there were no STK commands sent for SET_UP_MENU. Is it because a menu must be shown for every STK command?
Duplicate of this bug: 854352
This bug will be fixed as soon as bug 847040 is uplifted.
Depends on: 847040

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
blocking-b2g: tef? → ---
You need to log in before you can comment on or make changes to this bug.