If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Dialer]Accepting Incoming call when already in call is not hiding the accept/reject/ignore call option

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
--
critical
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Leo, Assigned: iliu@mozilla.com, ianliu.moz@gmail.com)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
1. Title : Accepting second incoming call by holding existing call doesnt hide the options accept,reject,ignore call 
2. Precondition : Existing Ongoing call
3. Tester's Action :
	           1) Get another incoming call 
		   2) In OnCall screen, touch on exisiting call number. It will put the existing call on hold and automatically accept the new call
		  
4. Detailed Symptom (ENG.) : It is observed that even after accepting call by the above actions ,  ( accept ,reject ,ignore call )options are still shown .
5. Gaia Version : a78ebf426840b5ef08c0cc3e437ad30aba3e2528
6. Expected : OPtions should be hidden when the call is already accepted ( output should be same as when we accept the new call by choosing accept button)
7.Reproducibility: Y
1)Frequency Rate : 100%
Created attachment 729537 [details]
Pointer to github's PR
Assignee: nobody → etienne
Attachment #729537 - Flags: review?(gtorodelvalle)
(Reporter)

Comment 2

5 years ago
I think that URL is https://github.com/mozilla-b2g/gaia/pull/8827 ( You upload wrong URL )
(Reporter)

Comment 3

5 years ago
I modify Expected result :

When touching on existing call number, cannot accept the new call.(no reaction in device)
Comment on attachment 729537 [details]
Pointer to github's PR

Simple and effective ;-) r+
Attachment #729537 - Flags: review?(gtorodelvalle) → review+
Sadly the requirements changed under our feet in Comment 3, so a new patch will be needed.
(Reporter)

Updated

5 years ago
Assignee: etienne → leo.bugzilla.gaia
(Reporter)

Comment 6

5 years ago
Created attachment 731052 [details]
Pull request URL 8884

When selecting existing number, check call state.

If 'incoming' call state exist, cannot accept call
Attachment #731052 - Flags: review?(etienne)
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
(Reporter)

Comment 7

5 years ago
Created attachment 731064 [details]
Bug_854786 video
Attachment #729537 - Attachment is obsolete: true
Comment on attachment 731052 [details]
Pull request URL 8884

No need to inspect all the calls, we can keep this strictly UI.

What we want is to ignore the clicks on the calls section [1] when we're displaying the call waiting UI.

So we can just add a condition in the |toggleCalls| function [2] that does an early return if |CallScreen.incomingContainer.classList.contains('displayed');|.

Thanks for taking this bug by the way!

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/oncall.js#L52-53

[2] https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/oncall.js#L573-575
Attachment #731052 - Flags: review?(etienne)
(Reporter)

Comment 9

5 years ago
Thank you for your advice!

I change source. Please review
(Reporter)

Updated

5 years ago
Attachment #731052 - Flags: review?(etienne)
Comment on attachment 731052 [details]
Pull request URL 8884

r=me with the lint issue fixed (extra space at the end of the line)
Attachment #731052 - Flags: review?(etienne) → review+

Updated

5 years ago
blocking-b2g: leo? → leo+
Bad user experience and unable to take second call, setting leo+
Sorry please disregard comment 11.

Corrected comment:
Triage on 4/2 - setting leo+ due to bad user experience and may cause confusion.
(Reporter)

Updated

4 years ago
Severity: normal → critical
Created attachment 753204 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9954

Pointer to Github pull-request
Comment on attachment 753204 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9954

Just keeping on the fixing process from comment 10.

Etienne,

Could you please help to review the pr again? Thank you.
Attachment #753204 - Flags: review?(etienne)
(Assignee)

Updated

4 years ago
Assignee: leo.bugzilla.gaia → iliu
Including Ayman as CC since he is currently checking the Call Waiting functionality ;-)
Comment on attachment 753204 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9954

Commented on github, should be quick to address :)
Attachment #753204 - Flags: review?(etienne)

Comment 17

4 years ago
Hey guys

Just out of curiosity why are we allowing the end user to interact with the blue bar at the top of the screen when a second call is incoming before they have interacted with any of the other CTAs on the screen ('end call', 'pause call', ' ignore call')? This behavior does not make any sense and was never specified. Refer to wireframe pack HTML5_Dialer_Contacts_20120810_R2S1_V6.0 pages 28 to 32 for specification.

Comment 18

4 years ago
Created attachment 753301 [details]
HTML5_Dialer_Contacts_20120810_R2S1_V6.0

Attached in relation to comment 17
Comment on attachment 753204 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9954

Etienne,
I agree with your suggestion. It's more clearly to distinguish 2 early return for 'toggleCalls()'.
Attachment #753204 - Flags: review?(etienne)
(In reply to ayman maat :maat from comment #17)
> Hey guys
> 
> Just out of curiosity why are we allowing the end user to interact with the
> blue bar at the top of the screen when a second call is incoming before they
> have interacted with any of the other CTAs on the screen ('end call', 'pause
> call', ' ignore call')? This behavior does not make any sense and was never
> specified. Refer to wireframe pack HTML5_Dialer_Contacts_20120810_R2S1_V6.0
> pages 28 to 32 for specification.

Hi Ayman,
For your question, we are fixing it in the issue.

Regarding to comment 0:
3. Tester's Action :
   1) Get another incoming call 
   2) In OnCall screen, touch on exisiting call number. It will put the existing call on hold and automatically accept the new call

(The exisiting call number should be equal to "on the blue bar at the top of screen".)

After the patch landed, It won't accept the second call on the blue bar at the top of screen while first call is active. Thanks for your point out:)
Comment on attachment 753204 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9954

Thanks!
Attachment #753204 - Flags: review?(etienne) → review+
Thanks for Etienne's reviewing effort. Since the pr landed, we can close the issue now.

master:   7878532edf5fe7b44d1889be6b736313b08cd47a
v1-train: f8cd3a5d6cf5a7789e4f6e635678842aeda42b31
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g18: --- → fixed
Resolution: --- → FIXED

Updated

4 years ago
Flags: in-moztrap?

Comment 23

4 years ago
Adding a related test case.
 - https://moztrap.mozilla.org/manage/case/8460/
Flags: in-moztrap? → in-moztrap-

Updated

4 years ago
Flags: in-moztrap- → in-moztrap+
You need to log in before you can comment on or make changes to this bug.