If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

impossible to add email address to address book - entry menu missing

RESOLVED INVALID

Status

SeaMonkey
MailNews: Address Book & Contacts
RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: zetka, Unassigned)

Tracking

SeaMonkey 2.17 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17
Build ID: 20130316231222

Steps to reproduce:

I would like to add address of the sender into the address book 


Actual results:

In the context menu when I click right or left mouse button, there are only following options:
address of the sender -grey
Compose mail to
Create Filter from
Edit Contact
Copy email adress



Expected results:

There should be entry with "Add to address book" as it is written in the help to Sea Monkey.
(Reporter)

Comment 1

5 years ago
It seems to be similar to https://bugzilla.mozilla.org/show_bug.cgi?id=130494

Comment 2

5 years ago
> Edit Contact
This means that the address is already in (one of your) addressbooks. What happens if you select this option?
(Reporter)

Comment 3

5 years ago
It seems that I am editing the adress book entry, but after pressing OK, the card is not in list of Personal Adress book but in collected addresses only. It seems that in case that the email is in collected adresses, it does not offer the "add to adress book". I have confirmed the behaviour on some really unknown email adress and the entry "add to addres book" is there.

Comment 4

5 years ago
Edit -> Preferences -> Mail & Newsgroups -> Addressing
Email Address Collection

Make sure that "Add email addresses to" is unchecked.

Comment 5

2 years ago
Of course the behaviour with the changing context menu entry isn't the best user interface being possible.  But it is not a bug.

If wanted please file a new Feature Request for a better solution.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.