[dialer] Dialing in airplane mode doesn't show a Notification Message

VERIFIED FIXED

Status

Firefox OS
Gaia::Dialer
--
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: AlinT, Assigned: etienne)

Tracking

({regression})

unspecified
regression
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed)

Details

(Whiteboard: [fromAutomation])

(Reporter)

Description

4 years ago
STR:
1.Switch Aiplane mode on
2.Enter the "Phone" app
3.Type a random phone number(ex: 0040556666)
4.Press Dial

Expected results:
A message box should appear, notifing you that you are in airplance mode.

Actual results:
Pressing Dial does do anything.
(Reporter)

Updated

4 years ago
Summary: [diale] Dialing in airplane mode doesn't show a Notification Message → [dialer] Dialing in airplane mode doesn't show a Notification Message
(Reporter)

Updated

4 years ago
Whiteboard: [fromAutomation]

Updated

4 years ago
Keywords: regression
Here's the manual test from which we created automation: https://moztrap.mozilla.org/manage/case/2282/

I should note that this is the Mozilla RIL; will put the Gecko/Gaia commit in the next comment.
Severity: normal → major
Gecko is: 28b048ffb7a7 / a800f14ea7022a78966f7fe14a9b0d11c569b151
Gaia v1-train is: 44f6a17f24d4
blocking-b2g: --- → leo?
The test is no longer failing on our nightly build nor on the up-to-the-minute v1-train build, so closing this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

4 years ago
QA Verified on build: 20130327230206
Status: RESOLVED → VERIFIED
So what fixed this?
(Reporter)

Comment 6

4 years ago
I haven't followed the commits in gaia, so I really can't say.
In the build from 26.03 this was a problem but in the build from 27.03 it was fixed.

Updated

4 years ago
blocking-b2g: leo? → -
Resolution: FIXED → WORKSFORME

Comment 7

4 years ago
This has regressed again on:
Build ID: 20130407230204
Gaia commit: v1train / 32bf502f086

Symptoms/ STR are identical
Status: VERIFIED → REOPENED
blocking-b2g: - → leo?
Resolution: WORKSFORME → ---
Assignee: nobody → etienne
blocking-b2g: leo? → leo+
(Assignee)

Comment 8

4 years ago
I can reproduce with a b2g18 build but not with a mc build.

Hsin-Yi, is there an easy way to check that bug 849185 got uplifted without any issue?
Flags: needinfo?(htsai)
Etienne,

I had tried the patch with both b2g18 and mc builds before I pushed it. Both worked. I guess I probably need some time to figure the issue out. Since I am joing a w3c meeting and may have limitied time working on the issue these days, would you please provide me logcat with RIL debug message first, so that I could have a glance and give you more useful feedback as soon ass possible? Thanks.
Flags: needinfo?(htsai)
(Assignee)

Comment 10

4 years ago
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #9)
> Etienne,
> 
> I had tried the patch with both b2g18 and mc builds before I pushed it. Both
> worked. I guess I probably need some time to figure the issue out. Since I
> am joing a w3c meeting and may have limitied time working on the issue these
> days, would you please provide me logcat with RIL debug message first, so
> that I could have a glance and give you more useful feedback as soon ass
> possible? Thanks.

== Mozilla central ==
I/Gecko   (25690): -*- RadioInterfaceLayer: Received
'RIL:RegisterMobileConnectionMsg' message from content process
I/Gecko   (25690): -*- RadioInterfaceLayer: Registered mobileconnection
target: [object ChromeMessageSender]
I/Gecko   (25690): -*- RadioInterfaceLayer: Received
'RIL:RegisterIccMsg' message from content process
I/Gecko   (25690): -*- RadioInterfaceLayer: Registered icc target:
[object ChromeMessageSender]
I/Gecko   (25690): -*- RadioInterfaceLayer: Received 'RIL:GetRilContext'
message from content process

(the call screen does not open and we see the error prompt telling us that we are in airplane mode)

== b2g18 ==
I/Gecko   (26017): -*- RadioInterfaceLayer: Received
'RIL:RegisterMobileConnectionMsg' message from content process
I/Gecko   (26017): -*- RadioInterfaceLayer: Registered mobileconnection
target: [object ChromeMessageSender]
I/Gecko   (26017): -*- RadioInterfaceLayer: Received 'RIL:Dial' message
from content process
I/Gecko   (26017): -*- RadioInterfaceLayer: Dialing 888
I/Gecko   (26017): -*- RadioInterfaceLayer: Received message from
worker:
{"rilMessageType":"callError","number":"888","isDialEmergency":false,"callIndex":-1,"errorMsg":"RadioNotAvailable"}
I/Gecko   (26017): -*- RadioInterfaceLayer: Received
'RIL:EnumerateCalls' message from content process
I/Gecko   (26017): -*- RadioInterfaceLayer: Requesting enumeration of
calls for callback
I/Gecko   (26017): -*- RadioInterfaceLayer: Received message from
worker:
{"requestId":"{0544ae2b-b652-466c-a498-3f9dd4b2b346}","rilMessageType":"enumerateCalls","calls":[]}
I/Gecko   (26017): -*- RadioInterfaceLayer: handleEnumerateCalls:
{"requestId":"{0544ae2b-b652-466c-a498-3f9dd4b2b346}","rilMessageType":"enumerateCalls","calls":[]}
I/Gecko   (26017): -*- RadioInterfaceLayer: Received
'RIL:RegisterTelephonyMsg' message from content process
I/Gecko   (26017): -*- RadioInterfaceLayer: Already registered this
target!
I/Gecko   (26017): -*- RadioInterfaceLayer: Received
'RIL:RegisterMobileConnectionMsg' message from content process
I/Gecko   (26017): -*- RadioInterfaceLayer: Already registered this
target!
I/Gecko   (26017): -*- RadioInterfaceLayer: Received
'RIL:SetMicrophoneMuted' message from content process
I/Gecko   (26017): -*- RadioInterfaceLayer: Received
'RIL:GetSpeakerEnabled' message from content process
I/Gecko   (26017): -*- RadioInterfaceLayer: Received 'RIL:StopTone'
message from content process
I/Gecko   (26017): -*- RadioInterfaceLayer: Stopping Tone

(the call screen pops up for a brief instant and we don't get the error prompt)

Hope it helps...
Entienne, I have a follow up patch for bug 849185. Some naming inconsistency between m-c and b2g18, sigh...
(Assignee)

Comment 12

4 years ago
The followup landed in B2G 18.
Just verified and this is fixed.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
status-b2g18: --- → fixed

Updated

4 years ago
Flags: in-moztrap?
(Reporter)

Comment 13

4 years ago
Verified on v1-train and v1.0.1
Status: RESOLVED → VERIFIED

Comment 14

4 years ago
This is already in Moztrap.
Suite: Dialer. Test case id: #2282
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.