Closed Bug 854992 Opened 7 years ago Closed 6 years ago

Make Contribute page automated emails subject lines localisable and customisable

Categories

(www.mozilla.org :: Bedrock, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kinger, Assigned: pmartins)

References

Details

(Whiteboard: [kb=1204235] )

Attachments

(1 file)

In a localised Contribute page form, when you submit it the automated responses have their subject lines in English while the body of the email 

Is it possible to make the subject lines localisable?
Priority: -- → P3
I was just looking at this. I think so, though it may be a little work just to make all the strings extractable.
Summary: Make Contribute page automated emails localisable → Make Contribute page automated emails subject lines localisable
Note that we'll also need to coordinate with Metrics on this, since the arewegrowingyet.com dashboard is using subject line information to track stats on inquiries.  Copying pmartins.
Blocks: 685675
Editing bug description -- the goal is to allow for localization of the subject line as well as customization (for example, in the same language the subject line for one functional area may be different from another).
Summary: Make Contribute page automated emails subject lines localisable → Make Contribute page automated emails subject lines localisable and customisable
Duplicate of this bug: 767463
Duplicate of this bug: 858824
Hi,

I want to bring attention to this bug again since I feel we are losing a lot of people on the localized versions because of this. People don't usually look at an email with the subject in English.

Even in English "Inquiry about X" sounds weird to me, like a robot replying, it would be better to have a "Welcome to Mozilla!" so people can get excited from the very first moment.

Is someone working on this?
Flags: needinfo?
Flags: needinfo?
Whiteboard: [kb=1204235]
Assignee: nobody → 6a68
I'm just getting started working (very part-time, 1/2 to 1 day a week) on this, struggling a bit with what the subject line should be changed to.

The current subject line is "inquiry about mozilla X", where X is localized.

Rather than localize that funny fragment and glue it together with the X, it seems better to just localize the whole thing--not every language would put the object of the preposition at the end of the sentence as English does.

The question is, what's a good replacement phrase? I'd really like to get input. Some ideas, using 'QA' as an example, instead of 'X':

"Thanks for asking about QA at Mozilla!"
"Welcome to Mozilla! Getting started with QA"
"Mozilla QA: welcome, and next steps"
"Contributing to QA at Mozilla"
"Details about helping QA at Mozilla"

I'm not blocked on this--I have code changes to make to accommodate the new subject line. It'd be great to get input, though.
My suggestion is: "Welcome to Mozilla!"

Short and direct. I don't see the need of having the area on the subject.
:Nukeador - that sounds great to me, I'll run with it.
I've just submitted a pull request to change the subject line[1] to "Welcome to Mozilla!", not distinguishing functional areas.

What corresponding changes would need to happen to ensure that metrics continues to measure the number of emails? We could add a custom email header maybe?

[1] https://github.com/mozilla/bedrock/pull/1523
Flags: needinfo?(pmartins)
(In reply to Rubén Martín [:Nukeador] from comment #8)
> My suggestion is: "Welcome to Mozilla!"
> 
> Short and direct. I don't see the need of having the area on the subject.

I personally do, at least to sort all the request that arrive.
(In reply to Francesco Lodolo [:flod] from comment #11)
> (In reply to Rubén Martín [:Nukeador] from comment #8)
> > My suggestion is: "Welcome to Mozilla!"
> > 
> > Short and direct. I don't see the need of having the area on the subject.
> 
> I personally do, at least to sort all the request that arrive.

+1, I also answer to people according to the subject line
As I pointed out on github the "Welcome to Mozilla!" is for the auto-responses, the "Inquiry about X" should be just for the email notification we get when someone fills the form, right now both email use the same subject.
Thanks for the feedback! I'll update the branch and resubmit the PR based on the comments.
Jared, thanks for working on this.  I definitely agree with Nukeador that the current subject line can be a blocker for many people receiving this email.

Before we make this change, I think we should he this discussion with all of the community builders who make use of this page to make sure they're aware of this and to see if they have suggestions or questions.

Jared or Nukeador, would you mind writing up a summary of the issue and the proposed change and post it to the community-building list at

https://mail.mozilla.org/listinfo/community-building
Great idea, David. Nukeador, thanks for pinging the list! I saw that nobody replied, so I've sent a followup[1]. (I couldn't reply to your email as I subscribed after the email was sent.) I'll work on the changes as nicely summarized in your email[2], and hopefully we'll at least get a few +1s before it's ready to be merged in--I don't want to break peoples' email filters without any feedback at all :-P

[1] https://mail.mozilla.org/pipermail/community-building/2014-January/001056.html
[2] https://mail.mozilla.org/pipermail/community-building/2014-January/001006.html
Flags: needinfo?(pmartins)
Comment on attachment 8358752 [details] [review]
updated pull request

David, would you mind reviewing the updated code? Nukeador, feel free to grab it if you have a free minute, too :-)
Attachment #8358752 - Flags: review?(dboswell)
Without seeing the previous changes to the email subject we get, it seems OK for the email people get.
I reviewed the pull request and would just like to confirm a few things:

* Have we confirmed that this doesn't break anything with the arewegrowingyet.com dashboard?  That dashboard is based on the mailman archives which captures the internal notification emails and not the auto-responses, but I'd like to make sure we confirm that this change won't break anything.

* I agree with Nukeador in comment #13 that changing the auto-response subject line is fine as long as it doesn't break the workflow people have around the internal notification emails.  Can we confirm that this is the case that those notification subject lines will stay the same.

* Does this change make the auto-response subject localizable?  It looks like it makes the subject more friendly, but will locales be able to localize it or is it still hard-code in English?
Thanks for looking, David! Answers below.

(In reply to David Boswell from comment #22)
> I reviewed the pull request and would just like to confirm a few things:
> 
> * Have we confirmed that this doesn't break anything with the
> arewegrowingyet.com dashboard?  That dashboard is based on the mailman
> archives which captures the internal notification emails and not the
> auto-responses, but I'd like to make sure we confirm that this change won't
> break anything.

I'm not sure about this, and I can't figure out where to find the relevant code, in order to poke at it a bit.

Do you have any idea who might be able to answer this definitively, maybe someone who touches the metrics code regularly?

> 
> * I agree with Nukeador in comment #13 that changing the auto-response
> subject line is fine as long as it doesn't break the workflow people have
> around the internal notification emails.  Can we confirm that this is the
> case that those notification subject lines will stay the same.

Yes, the only change is the subject line in the auto-response subject.

The subject line in the internal emails is unchanged[1].

> 
> * Does this change make the auto-response subject localizable?  It looks
> like it makes the subject more friendly, but will locales be able to
> localize it or is it still hard-code in English?

Yes, this change makes the subject line localizable.

The phrase is now wrapped in an _() call[2], which is an alias for the l10n function[3].

[1] (line 159) https://github.com/mozilla/bedrock/pull/1588/files#diff-101afe46fec28b6d3d4e493d5cc2b368R159
[2] (line 183) https://github.com/mozilla/bedrock/pull/1588/files#diff-101afe46fec28b6d3d4e493d5cc2b368R183
[2] (line 14) https://github.com/mozilla/bedrock/pull/1588/files#diff-101afe46fec28b6d3d4e493d5cc2b368R14
(In reply to Jared Hirsch [:_6a68] from comment #23)
> Do you have any idea who might be able to answer this definitively, maybe
> someone who touches the metrics code regularly?

Pedro Martins (pmartins) worked on that dashboard and would be able to confirm.  He's on this bug already and I'll ping him for more information.

> Yes, the only change is the subject line in the auto-response subject.
> 
> The subject line in the internal emails is unchanged[1].

Great.

> Yes, this change makes the subject line localizable.

Great.

Let's confirm about the metrics and we'll be all set.
Flags: needinfo?(pmartins)
Awesome! Thanks for driving this, David.
Bump. Pedro, have you had a chance to look at this?
David, thoughts on shuffling this bug forward?
Flags: needinfo?(dboswell)
Assigning to pmartins.  Pedro, please assign back to Jared after confirming that this change won't break the arewegrowingyet.com dashboard.

Jared, if we don't hear form pmartins in a few days, I'll try pinging him on IRC.
Assignee: 6a68 → pmartins
Flags: needinfo?(dboswell)
Hey David! Would you mind hitting up pmartins via whatever other channel seems best? Thanks again for your help wrangling this :-)
Flags: needinfo?(dboswell)
Ben, can you confirm that the change in this bug isn't going to break the arewegrowingyet.com dashboard please?  That dashboard is built off of the emails we get from the Get Involved page, so I just want to make sure we're not changing something that the dashboard is expecting.  Thanks.
Flags: needinfo?(dboswell) → needinfo?(bsullins)
David, is this the one you're referring to?

https://dataviz.mozilla.org/views/AreWeUnstuckYet/AreWeUnstuckYet
David is referring to http://arewegrowingyet.com/ but I have no idea where that comes from.
Digging in further, will have an update next week...
Flags: needinfo?(bsullins)
(In reply to Francesco Lodolo [:flod] from comment #32)
> David is referring to http://arewegrowingyet.com/ but I have no idea where
> that comes from.

Yes, that's the right dashboard.  The data for that dashboard comes from the mailing list archive of the contribute at mozilla dot org list.  The form on the Get Involved page CC's that mailing list on the email it sends out for each inquiry that comes through the form.
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/3a68124fd856d45427f6588f9e0b876de8695948
Merge pull request #1588 from 6a68/bug-854992-localize-contribute-email-subject-line

Bug 854992 Make subject line of contribute email for end-users localizable.
Whoops, looks like this was never closed. Closing
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Flags: needinfo?(pmartins)
Comment on attachment 8358752 [details] [review]
updated pull request

Unsetting stale flag
Attachment #8358752 - Flags: review?(dboswell)
You need to log in before you can comment on or make changes to this bug.