[B2G][Browser] While in the bookmark shortcut, opening a window.open link does not open in the browser

RESOLVED INVALID

Status

Firefox OS
Gaia::Browser
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: inarirun1)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Description:
 When a user opens a bookmark shortcut and taps on a window.open link, the link opens in the bookmark shortcut instead of the browser.

Repro Steps:
1) Updated to Unagi Build ID: 20130325070201
2) From the home screen go to Browser
3) In the address field type in www.news.google.com
4) Tap on "star" icon on the lower panel 
5) Choose and confirm "Add to Home Screen"
6) Go to the home screen
7) Open the new created shortcut "Google News"
8) Tap on any link

Actual:
The link opens in the bookmark shortcut instead of the browser

Expected:
The link opens in the browser. If the Browser app was just minimized and has content loaded in the different tabs the article will be opened in the new tab.

Environmental  Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/4931ec89ebbe
Gaia: 701b594c3e320030c538aa19f702764b29a6cc1c

Notes:
Repro frequency: 100%
Test Suite Name: Home/Homescreen/Wrapper
UCID: wrapper-003
https://moztrap.mozilla.org/manage/cases/?pagenumber=1&pagesize=20&sortfield=created_on&sortdirection=desc&filter-id=4073
Q Analysts Test Team Priority: (Priority Levels: Pri 2)
According to the bug 804569 per comment #2, long taping the link gives a suggestion to open the new page in the Browser. However, it does not work in the shortcut.
(Reporter)

Comment 1

5 years ago
Environmental  Variables:
Inari Build ID: 20130417070205
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6bac24e14538
Gaia: 2d048a9bdae54e4ec7d48326c2130591c8b869b6

Same issue reproduces on Inari device.
UCID: wrapper-003
Whiteboard: inarirun1
I've tried to debug this but I can't get Google to serve me the same version of Google News on the desktop.

How do you know they're using window.open and not a normal hyperlink?

I have actually found this quite annoying while dogfooding Google News, but as far as I can tell the system is behaving to specification.
Can we get some test cases from QA? I'd really like to figure out what's going on here because it's quite annoying but I don't think it's a bug.
Keywords: qawanted

Comment 4

5 years ago
Did you want test cases written for this?  There is a test case that this Bug was based off of in Comment 0.

Test Suite Name: Home/Homescreen/Wrapper
UCID: wrapper-003
https://moztrap.mozilla.org/manage/cases/?pagenumber=1&pagesize=20&sortfield=created_on&sortdirection=desc&filter-id=4073

I can do more research if this case isn't what you need.
Flags: needinfo?(bfrancis)
The problem with those test cases is that they make assumptions about the nature of the links of news.google.com

I'd like to know if those links are using window.open, target=_blank, or (as I suspect) they're just normal hyperlinks with no particular target. If that's the case then the wrapper is working to specification and we need to ask Google to send us a different version of Google News, as per bug 865043
Flags: needinfo?(bfrancis)
Using a user-agent and spoofing the Firefox OS user agent from here : https://developer.mozilla.org/en-US/docs/Gecko_user_agent_string_reference

I pulled the news.google.com up and then viewed the source:

<a target="_blank"class="article usg-AFQjCNE747JKGaBNNmgHjGtyj_NTrZZFSQ sig2-FwKDGhcPa8vWCZZv0kniNw did--2525232715131518378" href="http://www.guardian.co.uk/world/2013/may/08/brussels-airport-diamond-robbery-arrests" url="http://www.guardian.co.uk/world/2013/may/08/brussels-airport-diamond-robbery-arrests" id="MAA4AEgAUABgAWoCdXM"  ssid="h" >

it's using target="_blank"
Created attachment 747042 [details]
screenshot

I used a different mobile agent (Nexus One) and got a mobile version of the site.  Not sure if it's the same as the one we are getting for Firefox Mobile... It looks closer to what's on the phone.

<a class="fVjJ8e" href="/news/url?sa=t&amp;ct3=MAA4BEgCUAJgAmoCdXN6AnRj2AEB&amp;usg=AFQjCNG8A5F3xbxm4XiDjpmucYFYwkSyHQ&amp;rt=HOMEPAGE&amp;url=http://www.informationweek.com/software/productivity-applications/microsoft-opens-office-web-apps-to-andro/240154386&amp;ei=x5WKUcC3LKmgiQKVFw&amp;sig2=Cz4KX4dPz-jiQgrC7rXi9g" target="_blank" >
UA: Mozilla/5.0 (Linux; U; Android 2.2; en-us; Nexus One Build/FRF91) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Mobile Safari/533.1
Created attachment 747046 [details]
screenshot

Ben was right.  There's a difference with useragents for FF for Android :
Mozilla/5.0 (Android; Mobile; rv:13.0) Gecko/13.0 Firefox/13.0

No target listed...

Comment 10

5 years ago
Removing QAWanted as this has been answered by Naoki
Keywords: qawanted
I think the conclusion here is that there is no bug in B2G/Gaia, the version of news.google.com served for our UA string doesn't use window.open or target=_blank and therefore the test cases referenced in comment 4 are also invalid.

If we want Google News links to open in a new window then that requires outreach to Google as per bug bug 865043
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Comment 12

5 years ago
Test case 4073 has been updated.
You need to log in before you can comment on or make changes to this bug.