[B2G][Calendar] Swiping through Month View fast then rapidly switching to week view displays the day and date incorrectly

RESOLVED FIXED

Status

Firefox OS
Gaia::Calendar
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jeni, Assigned: kgrandon)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18+ fixed)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 729809 [details]
Calender-week view

Description:
After navigating through month view quickly and switching to week view the UI displayed multiple days and dates.

Repro Steps:
1) Updated to Unagi Build ID: 20130322070203
2) Tap on Calender
3) Scroll through the calender months at a quick rate (8 or 9 months)
4) Tap on Week view
5) View what happens

Actual:
After swiping thru month view to several months and then clicking on week view the date and day are displayed twice.

Expected:
See that the day and date are listed one time in week view.

Environmental  Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/4931ec89ebbe
Gaia: 85fd164691bb852f1cfaf82405df4380629ced6e

Also checked on Master 
Master build details
Unagi Build ID: 20130326031043
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/mozilla-central/rev/456cb08f8509
Gaia: d2a68bc3c26312bbd70c926aedbdef0fc972805e

Notes:
Repro frequency: 4/4, 75%,
See screenshot is attached.

This happens with or without calendar events.  Tested with google, yahoo, caldav accounts, by creating a long event span over a couple years, each were effected.  
Tested and affects both English and Spanish.
(Reporter)

Comment 1

5 years ago
Created attachment 729811 [details]
Logcat showing issue
(Reporter)

Comment 2

5 years ago
Created attachment 729815 [details]
Another picture showing issue
I can reproduce. This looks gross.

Edge case though, so doesn't block.
(Assignee)

Comment 4

5 years ago
Likely due to the way that the all-day events are constructed on the week view. I was actually working on another patch which should resolve this issue (it brings the all-day row into the week frame).
Assignee: nobody → kgrandon
(Assignee)

Comment 5

5 years ago
Created attachment 731260 [details]
Github pull request pointer
Attachment #731260 - Flags: review?(jlal)
Comment on attachment 731260 [details]
Github pull request pointer

Nice work!

In master: https://github.com/mozilla-b2g/gaia/commit/bdc26bc623b01d61d2f7748dcaa0d79650f1fd82
Attachment #731260 - Flags: review?(jlal) → review+
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 731260 [details]
Github pull request pointer

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): See bug details.
User impact if declined: Edge case where week view UI is terribly ugly.
Testing completed: Manual testing / unit test minor updates to ensure functionality works.
Risk to taking this patch (and alternatives if risky): None that I can think of that will make this problem worse. I can no longer reproduce the bug with this fix.
String or UUID changes made by this patch:
Attachment #731260 - Flags: approval-mozilla-b2g18?

Updated

5 years ago
Whiteboard: gaia-uplift
status-b2g18: --- → affected
tracking-b2g18: --- → +
Attachment #731260 - Flags: approval-mozilla-b2g18? → approval-gaia-v1+
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 bdc26bc623b01d61d2f7748dcaa0d79650f1fd82
  <RESOLVE MERGE CONFLICTS>
  git commit
We can't do more here without conflicts resolved. Please supply a patch or uplift directly.
Flags: needinfo?(kgrandon)
(Assignee)

Comment 10

5 years ago
Landed in v1-train: https://github.com/mozilla-b2g/gaia/commit/953d56bdb270dfa31c4cb903ac59830abac30f8e
status-b2g18: affected → fixed
Flags: needinfo?(kgrandon)

Updated

5 years ago
Whiteboard: gaia-uplift
You need to log in before you can comment on or make changes to this bug.