[Buri][BT]Can not unpaired device sometimes

RESOLVED WORKSFORME

Status

Firefox OS
Bluetooth
P2
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: sync-1, Assigned: shawnjohnjr)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #429217 +++
 
 Created an attachment (id=374002)
 adb logcat
 
 DEFECT DESCRIPTION:
 Can not unpaired device sometimes
 
 REPRODUCING PROCEDURES:
 1.Paired some other BT device,send file or do other actions
 2.Then idle test phone for some time
 3.Unpaired the paired device,find have no effect-->KO
 4.Turn off BT,then turn on,find the paired device have been unpaired
 
 EXPECTED BEHAVIOUR:
 For KO,should can unpair device
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 
 For FT PR, Please list reference mobile's behavior:
 
 AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.044
 Firefox os  v1.0.1
 Mozilla build ID: 20130319070203
 
 ++++++++++ end of initial bug #429217 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
 DEFECT DESCRIPTION:
 
 REPRODUCING PROCEDURES:
 
 EXPECTED BEHAVIOUR:
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 
 For FT PR, Please list reference mobile's behavior:

Comment 1

5 years ago
Created attachment 729942 [details]
adb logcat
(Reporter)

Comment 2

5 years ago
Dear Sir:
   Any updates ?

Updated

5 years ago
blocking-b2g: --- → tef?
(Assignee)

Updated

5 years ago
Assignee: nobody → shuang
Similar symptom was found, see bug 853056. Not pretty sure the root cause, I didn't find a STR, though. (Maybe it's because of using the invalid BluetoothAdapter object instance? If it's the case, then I guess it has been fixed.)
(Assignee)

Comment 4

5 years ago
Based on Comment 3, we suspected that this bug had been resolved. Change to qawanted for clarification.
Keywords: qawanted
(Assignee)

Updated

5 years ago
Component: Gaia → Bluetooth

Comment 5

5 years ago
Hi, all,

I can easy to reproduce this case on the earlier build(unagi) but cannot reproduce this case on latest build.
I think that Eric had a related patch to fix this bug.
Could reporter try this case again?
Thanks very much!

[Reproduction steps]
 1. Prepare two cell phones, we called "Phone-A" and "Phone-B"
 2. Using "Phone-A" to navigate to setting page
 3. "Phone-A" enables bluetooth then pair "Phone-B"
 4. After "Phone-A" paired "Phone-B" successfully, "Phone-B" disables bluetooth.
 5. "Phone-A" sends a picture to "Phone-B" then wait alarm message. 
 6. While Error/Fail message shown, "Phone-A" navigate to bluetooth setting page to unpair "Phone-B".

 - Expected result:
   "Phone-A" can unpair "Phone-B".
 - Actual result:
   "Phone-A" cannot unpair "Phone-B" and and Phone-B's device name still show on "Phone-A".

[Video record]
 https://dc1.beta.safesync.com/LMjcsYXb/Cannot_unpair_BT.3gp?a=sm4vfxuzQEE

[Test build]
* Mozilla-b2g18_v1_0_1-unagi-eng/2013-03-12-07-02-03 (Can reproduce)
  - Mercurial-Information
    + Gecko revision="cdf058e47197"
    + Gaia revision="3ca26e05cd94"
  - Git-Information
    + Gecko revision="b020ec20141b0d3141a7e82b1fbf981268c64994"
    + Gaia revision="1a6e1cd7715a5192b32db4b7127c5ae5b8162a7a"

* Mozilla-b2g18_v1_0_1-unagi-eng/2013-04-23-23-02-07 (Cannot reproduce)
  - Mercurial-Information
    + Gecko revision="a53c6262936d"
    + Gaia revision="04bad4955a8b"
  - Git-Information
    + Gecko revision="23488e3e96149244f13e8af5ad5f60c6834836b4"
    + Gaia revision="d5c25ace466dd56a941846bfd1b778ea8b7c376f"
  - Platform version
    + 18.0


Best Regards,
William
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Keywords: qawanted

Updated

5 years ago
blocking-b2g: tef? → ---
You need to log in before you can comment on or make changes to this bug.