The app should notice that network is down during an import contacts task

RESOLVED FIXED

Status

Firefox OS
Gaia::Contacts
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Jose Manuel Cantera, Assigned: Jose Manuel Cantera)

Tracking

unspecified
x86
Mac OS X
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
We need to be aware when the network is down during an import session for Contacts. The benefits will be 

A: We will avoid issuing HTTP requests for contact profile pictures as we know that those requests will fail
B: We can inform the user that the network was down and then he can decide whether to continue or to cancel the process. 

Disclaimers: In the case of FB if the user continues the profile pictures can be later downloaded during the automatic sync process. However for Hotmail and Gmail contacts as we don't have automatic sync the contacts will be stuck without photo forever and the only alternative for the end user will be to remove and import again the contact. For the reasons above I believe this bug should be leo+
(Assignee)

Updated

5 years ago
blocking-b2g: --- → leo?
(Assignee)

Updated

5 years ago
Assignee: nobody → jmcf

Comment 1

5 years ago
(In reply to Jose M. Cantera from comment #0)
> A: We will avoid issuing HTTP requests for contact profile pictures as we
> know that those requests will fail
> B: We can inform the user that the network was down and then he can decide
> whether to continue or to cancel the process. 

Jose - we'd take a low risk approval nomination for v1.1 depending on where we are in the cycle, but it's not clear this should be a blocker (didn't block v1.0.1).
blocking-b2g: leo? → -
tracking-b2g18: --- → +
(Assignee)

Comment 2

5 years ago
Created attachment 731787 [details]
Proposed copy for the message to be shown to the user
Attachment #731787 - Flags: feedback?(tyler.altes)
Attachment #731787 - Flags: feedback?(sergiov)

Comment 3

5 years ago
Proposed copy:

No Internet connection

Friends’ photos will not be added to your contacts. Continue anyway?
Depends on: 838051
Depends on: 838052, 838053, 838054
(Assignee)

Comment 4

5 years ago
Created attachment 731836 [details]
Pointer to GH PR #8914
Attachment #731836 - Flags: review?(crdlc)
I guess that buttons are wrong, according to the rest of Gaia should be "no | yes" the correct position
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 843683
Attachment #731787 - Flags: feedback?(sergiov) → feedback?(vpg)
Correct, the CTA (call to action) button should go on the right hand side of the screen. Copy wise, the most used lenguage is "Cancel" "OK".
(Assignee)

Comment 8

5 years ago
(In reply to Victoria Gerchinhoren from comment #7)
> Correct, the CTA (call to action) button should go on the right hand side of
> the screen. Copy wise, the most used lenguage is "Cancel" "OK".

thanks for the clarification, will proceed accordingly
Comment on attachment 731836 [details]
Pointer to GH PR #8914

It works pretty well. I disconnected my router while my phone was importing my friends and the curtain was displayed
Attachment #731836 - Flags: review?(crdlc) → review+
https://github.com/mozilla-b2g/gaia/commit/215e63acf16a033b2d26dbeedbd162a0ca3553c0
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 731836 [details]
Pointer to GH PR #8914

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: if phone loses connection while importing, the pictures won't appear on the contact list
Testing completed: yes
Risk to taking this patch (and alternatives if risky): low, it doesn't touch a lot of code related to contacts app, it is very isolated 
String or UUID changes made by this patch:
Attachment #731836 - Flags: approval-gaia-v1?
Attachment #731787 - Flags: feedback?(vpg)
Attachment #731787 - Flags: feedback?(tyler.altes)
status-b2g18-v1.0.1: --- → affected
status-b2g18: --- → affected
status-b2g18-v1.0.1: affected → ---
To fulfill one of the AC included in the witeframes for leo+ US 838051, 838052, 838053 and 838054 we need to land this patch in v1-train
(In reply to Maria Angeles Oteo:oteo from comment #12)
> To fulfill one of the AC included in the witeframes for leo+ US 838051,
> 838052, 838053 and 838054 we need to land this patch in v1-train

It would be good to see verification of this on master first also - those 4 bugs are leo+ and fixed so it's not clear how this bug is a requirement for them, and it's not a blocker (yet) - why is this required for AC but not nominated for blocking?
Keywords: verifyme
It was already nominated for blocker, not sure why it was refused. It's part of the AC included in the WF, if everything that is included there must be a blocker we should block on this
blocking-b2g: - → leo?
(In reply to Maria Angeles Oteo:oteo from comment #14)
> It was already nominated for blocker, not sure why it was refused. It's part
> of the AC included in the WF, if everything that is included there must be a
> blocker we should block on this

+1 to the leo nomination, without this requirement the functionality is broken, remember than in a mobile phone, loosing connectivity is something that will happen more than often.

Cheers.
You can check the Acceptace Criteria in the UX Wireframes in
Bug 844233, [UX Spec] Hotmail and Gmail contact import, 
all the Hotmail/Gmail Contacts import are linked to it:

Bug 838051 [Contacts][User Story] GMail contact import

Bug 838052 [Contacts][User Story] Hotmail contact import

Bug 838053 [FTESetup][User Story] GMail contact import

Bug 838054 [FTESetup][User Story] Hotmail contact import

If you check the WF, you can see in a general note:"Be sure to handle errors such as loss of connection and insufficient memory during import process"
That's the reason the development team has included this patch and need to uplifted, besides QA has included tests related to this AC so they will fail if we don't do it :(

Comment 17

5 years ago
From Alex K to me:

akeybl: can you confirm https://bugzilla.mozilla.org/show_bug.cgi?id=855246#c14?
[4:35pm] akeybl: if so, can you leo+?
[4:36pm] akeybl: I'm not sure where the WFs are, or whether this panel would be a feature blocker

I have confirmed with Maria about regarding the WFs per the information above. 

This should be Leo+. Thanks!
blocking-b2g: leo? → leo+
Attachment #731836 - Flags: approval-gaia-v1?
tracking-b2g18: + → ---
Uplifted commit 215e63acf16a033b2d26dbeedbd162a0ca3553c0 as:
v1-train: b05f49001b0fcf147a6d1ee5920be8303c1fe9f6
status-b2g18: affected → fixed

Updated

4 years ago
Flags: in-moztrap?

Updated

4 years ago
Flags: in-moztrap? → in-moztrap?(cschmoeckel)

Comment 19

4 years ago
Added Contacts App Suite Test Case #8986 - The Contacts App checks and notifies the user when no network is available during a import contacts app
Flags: in-moztrap?(cschmoeckel) → in-moztrap+

Comment 20

4 years ago
Verified fixed on leo Build ID: 20130723070209

Build ID: 20130723070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/68fb0a2e0114
Gaia: ffe25bfdf0e71c820ca710cb61fb8306564a8f4e
Platform Version: 18.1
RIL Version: 01.01.00.019.171 

User is notified when no network is available when importing contacts.

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified

Comment 21

4 years ago
Sorry, I didn't mean to change the status at the bottom, changing back to resolved, leaving tracking flag as verified.
Status: VERIFIED → RESOLVED
Last Resolved: 5 years ago4 years ago

Updated

4 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.