Closed Bug 855303 Opened 7 years ago Closed 3 years ago

[Mac OS] Silverlight issue - mouse cursor is stuck inside the plugin content

Categories

(Core :: Plug-ins, defect, P3)

20 Branch
x86_64
macOS
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: pauly, Assigned: smichaud)

Details

1. Open http://www.imagesurf.net/
2. Drag the mouse over the plugin content

AR: Unable to detach the cursor from the plugin content

Mac related only.
Old regression between FF 5 and 6.
I'll come back with a regression range.
Also check for a regression range in Silverlight versions.

Old versions are available here:
http://www.microsoft.com/getsilverlight/locale/en-us/html/Microsoft%20Silverlight%20Release%20History.htm
You need to uninstall a newer version of Silverlight before you can install an older version.  Here's how to do this:

On OS X 10.6 and below, you just need to delete the following:

/Library/Internet Plug-Ins/Silverlight.plugin
/Library/Receipts/Silverlight*.pkg

But the Silverlight*.pkg file doesn't exist on OS X 10.7 and above.  There you need to do the following instead:

sudo pkgutil --forget com.microsoft.SilverlightInstaller
(In reply to Steven Michaud from comment #1)
> Also check for a regression range in Silverlight versions.
But why would this matter if it's clearly a regression between FF 5-6 (works in 5, doesn't in 6)?
Because that regression between FF 5 and FF 6 may only exist for a very recent version of Silverlight.

This bug is bad enough that I think someone would have noticed it at the time, if it had started happening in FF 6.
Last good nightly: 2011-05-24
First bad nightly: 2011-05-25

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=456c915b3caf&tochange=836aa9658341
(In reply to Steven Michaud from comment #4)
> Because that regression between FF 5 and FF 6 may only exist for a very
> recent version of Silverlight
I'll work on this tomorrow.
(In reply to Paul Silaghi [QA] from comment #5)
> Last good nightly: 2011-05-24
> First bad nightly: 2011-05-25
> 
> Pushlog:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=456c915b3caf&tochange=836aa9658341

I suspect Bug 621117 - Support native cursor manipulation from OOP plugins on OS X
Priority: -- → P2
> I suspect Bug 621117 - Support native cursor manipulation from OOP plugins on OS X

So do I.

But that bug was specifically targeted at Flash and Silverlight -- to allow them to continue using old-fashioned (QuickDraw) calls to manipulate the cursor when running OOP.  And a lot of testing was done at the time of cursor manipulation in both Flash and Silverlight.  So if this bug existed at the time we almost certainly would have caught it.

So someone really does need to check the regression range for this bug in Silverlight versions.

We may find that the patch for bug 621117 is no longer needed in current versions of Flash and Silverlight, and that it can (now) be backed out.  But a lot of testing will be required before we can arrive at that conclusion.
> But that bug was specifically targeted at Flash and Silverlight --
> to allow them to continue using old-fashioned (QuickDraw) calls to
> manipulate the cursor when running OOP.

Similar workarounds existed in Chromium, which I adapted when writing
the patch for bug 621117.  Someone should check if they're still in
current versions of Chromium.
Indeed there seems to be also a regression in Silverlight versions.
With Build 4.1.10111.0 the problem is not reproducible on the latest nightly.
With Build 5.0.61118.0 the regression range in comment 5 still stands.
The latest 4.x version is no longer available, and the firsts 5.x versions are recognized to be outdated and the content of the page is not displayed. So I couldn't find the exact regression range between Silverlight versions.
We need to find a Microsoft contact for Silverlight, who can tell us whether or not current versions still need the workarounds landed in the patch for bug 621117.
We should ask Adobe the same question.  But since this bug only concerns Silverlight, I'll do that at bug 621117.
I'm probably best suited to work on this bug.  But it'll be a while before I can devote time to it.

In the meantime we should try to get a definitive answer from Microsoft to my question from comment #11.
Assignee: nobody → smichaud
Paul, I assume you see this bug with the current versions of both Firefox and Silverlight.

What version(s) of OS X did you test on?
OS X 10.7.5
Priority: P2 → P3
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.