Support multiple installs of Firefox

RESOLVED INVALID

Status

Tracking
Metro Operations
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: bbondy, Unassigned)

Tracking

({meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tracking])

(Reporter)

Description

5 years ago
This is for general cleanup of multiple installs.  I'm adding it to v1 backlog as a p5 for now.
(Reporter)

Updated

5 years ago
Blocks: 838081
(Reporter)

Updated

5 years ago
Depends on: 841610
(Reporter)

Updated

5 years ago
Depends on: 844424
(Reporter)

Updated

5 years ago
Depends on: 844428
(Reporter)

Updated

5 years ago
Depends on: 844646
Whiteboard: p=13
(Reporter)

Updated

5 years ago
Whiteboard: p=13 → p=8
(Reporter)

Updated

5 years ago
Depends on: 846597
Hi Asa, requires story requirements, an epic to be related to and whiteboard tagging.
Flags: needinfo?(asa)
QA Contact: jbecerra
Whiteboard: p=8 → feature=story c=tbd u=tbd p=8
(Reporter)

Comment 2

5 years ago
Questions for story:
Do we want multiple installs to have multiple start screen shortcuts? Or simply only the default has a start screen shortcut? (Only the default would be a metro tile for sure)

Comment 3

5 years ago
This can block the epic bug 831560. 

Brian, is the goal here to make it easier for our testers to run two different versions or is there something for our release users here?

I'm fine with this being on our radar for v1, especially if we can pick off one or two of the lower hanging fruit work items that would make testing easier. I don't think it's a high priority though (as bbondy noted.)
Flags: needinfo?(asa) → needinfo?(netzen)

Updated

5 years ago
Blocks: 831560
(Reporter)

Comment 4

5 years ago
It's mostly for users who are using builds from 2 different channels on the same computer, so ya I think this is mostly for testers.  Blocked bug 831560.
Flags: needinfo?(netzen)
(Reporter)

Updated

5 years ago
Depends on: 872012
(Reporter)

Updated

5 years ago
Whiteboard: feature=story c=tbd u=tbd p=8 → feature=story c=tbd u=tbd p=13

Updated

5 years ago
Whiteboard: feature=story c=tbd u=tbd p=13 → feature=story c=Other_charms_and_integration u=metro_firefox_user p=13

Updated

5 years ago
Blocks: 861680
No longer blocks: 831560, 838081
QA Contact: jbecerra
Whiteboard: feature=story c=Other_charms_and_integration u=metro_firefox_user p=13 → feature=story c=Other_charms_and_integration u=metro_firefox_user p=0
(Reporter)

Updated

5 years ago
Duplicate of this bug: 881826
(Reporter)

Updated

5 years ago
Depends on: 881826
(Reporter)

Updated

5 years ago
No longer depends on: 881826

Updated

5 years ago
Depends on: 888363

Updated

5 years ago
Priority: P5 → --

Updated

5 years ago
Summary: Story - Support multiple installs of Firefox → Support multiple installs of Firefox
Whiteboard: feature=story c=Other_charms_and_integration u=metro_firefox_user p=0 → [story]

Updated

5 years ago
Depends on: 918253, 918287, 918918, 919811
Hi Brian,
I'm trying to see if this requires UX work. But I'm not sure I completely understand the concept of multiple install. Could you please explain any change this will have from user-facing perspective? And what's the difference with the shared profile work we have implemented. 

Thanks!
Flags: needinfo?(netzen)
(Reporter)

Comment 7

5 years ago
I think this is all registry settings and other config for controlling win8 UI. I don't think there would be any Firefox UI involved.
Flags: needinfo?(netzen)
Keywords: meta

Updated

4 years ago
Whiteboard: [story] → [tracking]
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.