Closed Bug 855518 Opened 7 years ago Closed 7 years ago

Make monospace font readable and consistent across devtools

Categories

(DevTools :: Inspector, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 905312

People

(Reporter: vporof, Assigned: harth)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

After bug 836233, the markup view text seems a bit smaller than usual (vertically undersized), and is especially hard to read (on OS X at least). Compared to the source editor text, it's about half the size, from what I can tell.
Blocks: 836233
Blocks: 858765
Assignee: nobody → fayearthur
Trying some stuff out. It seems to be a decent size on Windows and Linux. The Network panel had it's own monospace font, so I gave it the devtools-monospace class instead.
(I'd like to review that when it's ready)
Comment on attachment 791583 [details] [diff] [review]
WIP, increase "devtools-monospace" size on OS X, use in net panel

Review of attachment 791583 [details] [diff] [review]:
-----------------------------------------------------------------

This does a few things:

* Netmonitor now uses "devtools-monospace" class instead of hard-coding its monospace font
* Font panel now uses "devtools-monospace" and doesn't define its own sizes.
* On OS X, monospace font size is increased to %110. The other platforms look alright size-wise (aside from the font panel).
* Fix margin issue in font panel.
Attachment #791583 - Flags: review?(paul)
Summary: Markup view text is maybe a bit too small → Make monospace font readable and consistent across devtools
Attached patch font-size.patchSplinter Review
Patch, goes along with notes in last comment ^.


Try builds: http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/fayearthur@gmail.com-7635c7cbcde8/
Attachment #791583 - Attachment is obsolete: true
Attachment #791583 - Flags: review?(paul)
Attachment #792363 - Flags: review?
Attachment #792363 - Flags: review? → review?(paul)
Comment on attachment 792363 [details] [diff] [review]
font-size.patch

Gonna tackle web console too. I'll upload a new patch.
Attachment #792363 - Flags: review?(paul)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 905312
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.