[B2G][Dialer] A missed call from saved on the device contact does not appear on the lock screen.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Mila Davydova, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

333.01 KB, text/plain
Details
(Reporter)

Description

5 years ago
Created attachment 730452 [details]
logcat

Description:
When user resets the device and receives a missed call from the saved on the device contact, the missed call details do not appear on the lock screen and no missed call notification is received after the call is ended. This issue occurs only when a missed call is received for a first time.

Repro Steps:
1) Updated to Unagi Build ID:20130327070202
2) Go to the Contacts app
3) Create a contact
4) Lock the phone
5) Receive a  Missed call from the saved on the device contact 
6) Observe the lock screen and notification

Actual:
- Missed call does not appear on the lock screen after the call is ended
- Missed call notification is not received on the device 

Expected:
- Missed call is displayed on the lock screen
- User receives a missed call notification 

Environmental  Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/879324d41588
Gaia: e7e7c1a473b4069544f2dad779b1c9b1bab91663

Notes:
Repro frequency: 100% on multiple Unagi devices
Q Analysts Test Team Priority: Pri 3
See attached logcat for more info
(Reporter)

Updated

5 years ago
Blocks: 832841
Hi Mila! I found this bug in my bug queue :p and felt curious about it so I tested it and, at least in my case (latest Gecko and Gaia), I am not able to reproduce it :-) Could you please re-test it and, in case it is solved, mark it as "works for me" please? Thanks! ;-)
Flags: needinfo?(mdavydova)
(Reporter)

Comment 2

5 years ago
I was not able to reproduce this issue with the latest Unagi build.
When user receives a missed call from the saved on the device contact the notification of a missed call displays on the lock screen and notification bar as soon as the call is ended.

Unagi Build ID: 20130530070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/09ac1fd2959c
Gaia: 1cca9324d4444ad28c6fa99875e17abf7e8230be
Version 18.0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mdavydova)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.