PDF attachments showing as winmail.dat

RESOLVED DUPLICATE of bug 77811

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 77811
5 years ago
5 years ago

People

(Reporter: Stefano, Unassigned)

Tracking

17 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 730575 [details]
thunderbird screenshot

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307122903

Steps to reproduce:

A friend sent me an email with a pdf attached.


Actual results:

I see it as a generic winmail.dat attachement instead of the pdf. Google mail shows it correctly. (see screenshots)


Expected results:

It should show the attachment like gmail (New Sync-Gen II Manual Release V104 July 2012.pdf)
(Reporter)

Comment 1

5 years ago
Created attachment 730576 [details]
gmail screenshot
(Reporter)

Comment 2

5 years ago
Created attachment 730577 [details]
the email

Comment 3

5 years ago
Comment on attachment 730577 [details]
the email

That's because it indeed *has* a winmail.dat attachment...

Relevant message headers:

> X-MS-Has-Attach: yes
> X-MS-TNEF-Correlator: <D9D0CF1DEFDCE3468B80294416C3CCAC396C56AF@sgbecmb01>

Attachment headers:

> Content-Disposition: attachment; filename="winmail.dat"
> Content-Transfer-Encoding: base64
> Content-Type: application/ms-tnef; name="winmail.dat"

This is a proprietary Microsoft format used in their Outlook and Exchange products. Tell the sender to send "HTML" rather than "Rich Text Format" messages to resolve the issue at the source.

Alternatively, there is an extension to unpack such TNEF attachments:
https://addons.mozilla.org/thunderbird/addon/lookout/ (may need tweaking to work with 17.0.x, see review comments).
Attachment #730577 - Attachment mime type: application/octet-stream → text/plain

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 77811
(Reporter)

Comment 5

5 years ago
From a user perspective, since other mail clients are capable of showing the right content, this is defeinitely a problem, regardless the technical details.
Thanks for taking the time to look into this. I will follow the master bug.
You need to log in before you can comment on or make changes to this bug.