Add a more detailed alloc size breakdown to DMD reports

RESOLVED DUPLICATE of bug 1044709

Status

()

RESOLVED DUPLICATE of bug 1044709
6 years ago
4 years ago

People

(Reporter: justin.lebar+bug, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Right now DMD reports only the total size of all allocs with a given stack trace.

But DMD actually has a lot more information than that: It knows the precise size of all allocs greater than 4093 bytes.

Sometimes it would be useful to have this precise information.  For example, in bug 846903, I see one stack trace which has a few thousand allocs.  But I now suspect that most of those are very small, and only a few are large.  Getting the precise number would be helpful, because it might be that we're getting one large alloc per picture taken on the camera, or maybe only one large alloc at all.

I'm not quite sure how to do this without overwhelming the DMD output.  We'll probably have to limit how many size classes we display?
Depends on: 1044709
Blocks: 1058178
The draft patch in bug 1044709 implements this via dmd.py's --show-all-block-sizes option.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1044709
You need to log in before you can comment on or make changes to this bug.