Unread mail status is incorrectly set to Read when mail filtered to local folder

VERIFIED FIXED in mozilla0.9.5

Status

MailNews Core
Database
P2
normal
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Jozef Chocholacek, Assigned: Bienvenu)

Tracking

Trunk
mozilla0.9.5

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

2.90 KB, application/octet-stream
Details
1.93 KB, patch
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

17 years ago
When messages are moved (using filters) from IMAP Inbox to the apropriate
subfolders in "Local Folders", some of them are marked Read although they arent
read (e.g. during night when my Mozilla is running and retrieving new messages,
but I am sleeping home so I cannot read the messages :).

Comment 1

17 years ago
Reporter what build are you using? Have you tried 0.9.2 and a new profile does
that fix the problem?
(Reporter)

Comment 2

17 years ago
Now I am on 0.9.2 and this bug is still there. Build ID is 2001070209.
I found out that it is the last received message in the folder, e.g. I have set
to connect to IMAP every 15 min. and receive new messages and sort them into
local folders - and when there is e.g. 5 new messages, then the newest message
(with highest "Date" field) is marked as read.
Do you want my configuration?

Comment 3

17 years ago
yes please

Comment 4

17 years ago
Created attachment 41797 [details]
Configuration files from user

Comment 5

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 6

17 years ago
changing summary; Navin, do you have a bug like this?
Status: NEW → ASSIGNED
Summary: Unread mail status is incorrectly set to Read → Unread mail status is incorrectly set to Read when mail filtered to local folder

Comment 7

17 years ago
No
(Assignee)

Comment 8

17 years ago
*** Bug 94604 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

17 years ago
This is also true when copying multiple unread messages from imap to pop - the
last message gets marked read. So the problem is in the msg copy code, not the
filter code.
OS: Linux → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → mozilla0.9.4
(Assignee)

Comment 10

17 years ago
OK, the problem here is that nsMsgLocalMailFolder::CopyMessagesTo calls
StartMessage() for the first local message. However, we don't need this if the
src folder is imap because IMAP will do a StartMessage for each message. The fix
will probably be to check if the src folder is imap, unfortunately, or some
similar hack.

Comment 11

17 years ago
David I was going to bump this to .9.5 per the triage meeting today but it
sounds like you may already have a fix. If you do, go ahead & check it in
otherwise feel free to push this off to .9.5.

Comment 12

17 years ago
bumping to .9.5 per my earlier comment.
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Updated

17 years ago
QA Contact: esther → laurel
(Assignee)

Comment 13

17 years ago
Created attachment 50339 [details] [diff] [review]
proposed fix
(Assignee)

Comment 15

17 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
OK using nov15 commercial trunk build: win98, mac OS X, linux rh6.2
OK for filtering (multiple messages arriving at a time) IMAP --> local, OK for
copying multiple messages IMAP --> local.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.