B2G MMS: delivery is not correctly indexed in DB

RESOLVED FIXED in Firefox 22

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: airpingu, Assigned: airpingu)

Tracking

Trunk
mozilla22
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:leo+, firefox20 wontfix, firefox21 wontfix, firefox22 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix)

Details

Attachments

(1 attachment)

Since the delivery is now determined by the caller site, which means the MMS' delivery can be either of DELIVERY_RECEIVED or DELIVERY_NOT_DOWNLOADED, the delivery index cannot be hard-coded like SMS. This would fail the delivery filtering.
Summary: B2G MMS: delivery is not correctly indexed → B2G MMS: delivery is not correctly indexed in DB
Posted patch PatchSplinter Review
Attachment #731044 - Flags: review?(vyang)
Attachment #731044 - Flags: feedback?(ctai)
Comment on attachment 731044 [details] [diff] [review]
Patch

Review of attachment 731044 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to, thanks.
Attachment #731044 - Flags: feedback?(ctai) → feedback+
(In reply to Chia-hung Tai [:ctai :ctai_mozilla :cht] from comment #2)
> Comment on attachment 731044 [details] [diff] [review]
> Patch
> 
> Review of attachment 731044 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Looks good to, thanks.
Looks good to me, thanks.
Attachment #731044 - Flags: review?(vyang) → review+
Comment on attachment 731044 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): not yet reported as a bug but it's actually a follow-up correctness for Bug 845643.
User impact if declined: without the patch, we cannot correctly search the MMS messages with delivery == "not-downloaded".
Testing completed: yes
Risk to taking this patch (and alternatives if risky): absolutely no. This patch only corrects the MMS codes for constructing the delivery index for DB searching. SMS is not affected.
String or UUID changes made by this patch: no
Attachment #731044 - Flags: approval-mozilla-b2g18?
leo+ as this is a part of MMS. No_UPLIFT for now before the whole MMS is completed
blocking-b2g: --- → leo+
Whiteboard: NO_UPLIFT
Comment on attachment 731044 [details] [diff] [review]
Patch

All right... Let's remove approval-mozilla-b2g18 because of NO_UPLIFT and leo+.
Attachment #731044 - Flags: approval-mozilla-b2g18?
https://hg.mozilla.org/mozilla-central/rev/ac442ffde0bc
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
Flags: in-moztrap-
You need to log in before you can comment on or make changes to this bug.