If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

codeguru.com - mixed ISO and UTF-16 in same document

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English Other
P3
major
RESOLVED INVALID
17 years ago
3 years ago

People

(Reporter: Bernard Alleysson, Unassigned)

Tracking

Details

(Whiteboard: [SYNTAX-HTML], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.1+)
Gecko/20010513
BuildID:    2001061311

asian text is displayed instead of english ?

Reproducible: Always
Steps to Reproduce:
1.go to URL
2.try to read text (good luck)
3.

Actual Results:  display is not in english

Expected Results:  display english text

to see what I mean look the page in IE

Comment 1

17 years ago
seen from the linux version of moz, all the text is there, but not with the
intended format. In addition, a square displays between each and every
character, leaving it pretty unreadable.

The page uses some scripting to "demonstrate a bug in Netscape 4". (NC4 doesn't
display the main area at all)

View source in mozilla shows the text without the squares, but it all comes
through as double-spaced, including tags. Not sure whether this is funny CSS or
browser sniffing. Trying DOM0 for starters.
Assignee: asa → jst
Status: UNCONFIRMED → NEW
Component: Browser-General → DOM Level 0
Ever confirmed: true
QA Contact: doronr → desale
OK.  Here's what's up.  The page has:

    <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">

Then it has 16-bit chars in the main content area!  A hex dump looks like:

0a00 3c00 4300 4500 4e00 5400 4500 5200
3e00 3c00 4800 3300 3e00 3c00 4600 4f00

That says " <CENTER><H3><FO", but with null bytes between the characters.  The
page continues in this vein for a while.

Over to i18n to figure out what to do with this one...
Assignee: jst → nhotta
Component: DOM Level 0 → Internationalization
QA Contact: desale → andreasb
(Reporter)

Comment 3

17 years ago
looks like HTML text with UNICODE chars...
Well, yes.  But the page explicitly says that it's in iso-8859-1.  Then it gives
us Unicode...  And we display it as iso-8859-1, naturally.

Comment 5

17 years ago
Switching QA contact to ylong.
QA Contact: andreasb → ylong

Comment 6

17 years ago
This is invalid, META charset and the actual data in the page do not match.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Reopening to reassign to evang
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
-->evang
Assignee: nhotta → bclary
Status: REOPENED → NEW
Component: Internationalization → Evangelism
QA Contact: ylong → zach

Updated

17 years ago
Priority: -- → P3
Whiteboard: [SYNTAX-HTML]

Comment 9

16 years ago
-> Intl because of topic area
Assignee: bclary → nitot
QA Contact: zach → momoi
Summary: international text displayed → codeguru.com - international text displayed

Updated

16 years ago
Component: Evangelism → European
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 10

16 years ago
->Non US English
Assignee: nitot → momoi
Component: European → Non-US English
QA Contact: momoi → jonrubin

Comment 11

16 years ago
jonrubin@netscape.com is no longer here, switching QA contact to ruixu@netscape.com.
QA Contact: jonrubin → ruixu

Comment 12

15 years ago
The characters "ÿþ" are the hex FF FE UTF-16 byte order mark.
OS: Windows NT → All
Hardware: PC → All
Summary: codeguru.com - international text displayed → codeguru.com - mixed ISO and UTF-16 in same document

Comment 13

15 years ago
Mass reassigning English-Other bugs to general default assignees.
Assignee: momoi → english-other
QA Contact: ruixu → english-other
The page http://www.codeguru.com/string/Multilingual.html doesn't exist anymore.
(Reporter)

Comment 15

14 years ago
well, the page has gone
Status: NEW → RESOLVED
Last Resolved: 17 years ago14 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.