If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Reseting the phone from Settings bricks it

RESOLVED WORKSFORME

Status

Firefox OS
Gaia
--
major
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: julienw, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18-)

Details

(Reporter)

Description

5 years ago
STR:
* open Settings app
* go to Device Information > More information
* choose "Reset Phone"

Expected:
* the phone should reboot in a "reseted" state

Actual
* the phone reboots, we see the "android" image and we see something happening. however after this finishes the phone is not usable anymore.

The only way to unbrick it was to put it in "fastboot" mode and flash it.

For v1 we should at least remove the "reset" button. The best would be to fix the function of course.
(Reporter)

Updated

5 years ago
Severity: normal → major
qawanted to try to reproduce this in v1.0.1. Julien, do you know which recovery image did you have in your brick... err device?
Keywords: qawanted

Comment 2

5 years ago
I tested w/ the nightly build from the pvtbuild server on my unagi phone.
I cannot reproduce it. My phone was reset and started from FTU as expected.

git.mozilla.org
gaia:  af7447ccc38559868a2bd1dcfa03b4444ef5591e
gecko: 630fdb0e9617d59ff65c649ad68d0c4735db6bc7

Julien, can you provide more detail information? thanks.
Flags: needinfo?(felash)
Keywords: qawanted
Cannot reproduce it either, can you please check it again with latest 1.0.1 build?
blocking-b2g: tef? → -
(Reporter)

Comment 4

5 years ago
just tried both 1.0.1 and 1.1 user builds and it works actually properly.

I'm trying now with an eng build.
Flags: needinfo?(felash)
(Reporter)

Comment 5

5 years ago
An eng build works too.

However, I reproduce when I reset from a custom build.

I don't really know what difference between the pvt builts and my custom build could produce this bug.
julienw, fyi you need the FOTA installer change as well in order not to see the android image.  I had asked this question before and was pointed to it.
Given comments 3,4,5 resolving WFM.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
tracking-b2g18: ? → -
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

5 years ago
Can't we investigate why a build from the standard B2G repository triggers this ?
You need to log in before you can comment on or make changes to this bug.