URL is still predicted despite history/cache being cleared

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: Alan, Unassigned)

Tracking

19 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

Beginning to type a previously visited URL into the browser window, somehow allows the browser to predict the URL that I am going to type, even though I have previously cleared the cache. It is restored from the local PC and is not predicted using a search engine or similar.


Actual results:

It does not remember ALL URL's, only frequently visited ones.
It does not remember subdomains, only actual domains.


Expected results:

No memory of the previously visited URL should be retained. It should have NO IDEA what URL I am about to type.
(Reporter)

Updated

5 years ago
Component: Untriaged → Bookmarks & History
And you type a page that you didn't bookmarked ?

Updated

5 years ago
Flags: needinfo?(alan.cocox)
Clearing the cache is unrelated, you should clear history...
(Reporter)

Comment 3

5 years ago
(In reply to Matthias Versen [:Matti] from comment #1)
> And you type a page that you didn't bookmarked ?

Correct. It only predicts whole domains, not sub-domains or files.

Try it with a website you frequently visit.
Flags: needinfo?(alan.cocox)
(In reply to Alan from comment #3)
> (In reply to Matthias Versen [:Matti] from comment #1)
> > And you type a page that you didn't bookmarked ?
> 
> Correct. It only predicts whole domains, not sub-domains or files.
> 
> Try it with a website you frequently visit.

I can't reproduce this as described. See also comment 2 - clearing the cache has no effect on this.

After removing all history, I do notice the URLBar suggest bookmarked pages and also the top-level domain of bookmarked pages, but never see it suggest something that was previously in my history but no longer is.

Please reopen with more detailed STR if you think this remains a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.