[Buri][Shira-48097][Browser]Browser does not provide a mechanism to dial phone numbers out of web pages

RESOLVED DUPLICATE of bug 838043

Status

P2
normal
RESOLVED DUPLICATE of bug 838043
6 years ago
5 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: Poland, IOT, Buri)

(Reporter)

Description

6 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.044
  Firefox os  v1.0.1
  Mozilla build ID: 20130319070203
 
 +++ This bug was initially created as a clone of Bug #431522 +++
 
 DEFECT DESCRIPTION:
 [TMO-48097][Browser]Browser does not provide a mechanism to dial phone numbers out of web pages.
 
 REPRODUCING PROCEDURES:
 1.connect to wifi or enable data connection
 2.open www.baidu.com, search 13817333239
 3.choose the second wenstie which contains a phone number
 4.the user has no mechanism to dial this phone number. There's no copy'n'paste or phone number recognition on websites.---KO
 
 EXPECTED BEHAVIOUR:
 Since this feature is supported by every other platform, to improve customer experience, the handset should provide a mechanism to dial phone numbers.
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:5/5
 
 For FT PR, Please list reference mobile's behavior:
 For reference phone Telsa orange:
 short click the phone number, it jumps to the call interface,refer to screenshot.
 Long press the phone number, it pops up menu for user to choose next step,refer to screenshot.
 
 ++++++++++ end of initial bug #431522 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:

Updated

6 years ago
Summary: [Buri][TMO-48097][Browser]Browser does not provide a mechanism to dial phone numbers out of web pages → [Buri][Shira-48097][Browser]Browser does not provide a mechanism to dial phone numbers out of web pages

Updated

6 years ago
blocking-b2g: --- → tef?
v1.0.1 supports phone number invocation if the number includes the tel: prefix. The rest of comments seems to me like a feature request for 1.0.1 and hence would like ffos product team to decide here.
Flags: needinfo?(ffos-product)
Duplicate of bug 838043 ?
(In reply to Ben Francis [:benfrancis] from comment #2)
> Duplicate of bug 838043 ?

Yes

838043 is not critical priority, but may be considered in the future.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(ffos-product)
Resolution: --- → DUPLICATE
Duplicate of bug: 838043
blocking-b2g: tef? → -

Updated

6 years ago
Blocks: 869681

Updated

6 years ago
Whiteboard: Poland, IOT, Buri
(Reporter)

Comment 4

5 years ago
This bug marked as KOI,
 
 https://bugzilla.mozilla.org/show_bug.cgi?id=838043
 
 won't fixed on v1.1
You need to log in before you can comment on or make changes to this bug.