Closed Bug 856657 Opened 9 years ago Closed 9 years ago

Go/Search icons in URL bar and keyboard can get out of sync

Categories

(Firefox for Android Graveyard :: Awesomescreen, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 23

People

(Reporter: jchen, Assigned: jchen)

Details

(Keywords: reproducible)

Attachments

(1 file, 1 obsolete file)

For example, the URL bar could display Search icon while the keyboard displays Go icon.
STR

i) Enter 'mozilla ' (mag glass)
ii) Hit backspace 'mozilla' (mag glass; should be arrow -> keyboard has 'Go')

--
Nightly (04/01), Nexus 4 (Android 4.2.2)
Keywords: reproducible
The keyboard's go/search icon changes when we reset the input; we should change the button at that time as well for consistency.
Attachment #735314 - Flags: review?(cpeterson)
Comment on attachment 735314 [details] [diff] [review]
Change Go button at the same time as resetting input (v1)

Review of attachment 735314 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!

This fix looks like a good candidate for a UI polish bug that could be uplifted to Aurora. We're still early in this release cycle.

::: mobile/android/base/AwesomeBar.java
@@ +367,2 @@
>          }
>      }

Can we consolidate the duplicated restartInput/setImageResource/setContentDescription code to the end of the method using a "restartInput" (or whatever) local boolean variable?
Attachment #735314 - Flags: review?(cpeterson) → review+
Deduplicated code; carrying over r+




Change Go button at the same time as resetting input (v1)
Attachment #735863 - Flags: review+
Attachment #735314 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/5820dbc75b5a
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.