[FHR] FHR bookmarks not correct

VERIFIED WORKSFORME

Status

Firefox Health Report
Web: Health Report
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Annie Elliott, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
The vital showed that I had 57 bookmarks. I added 3 more, expecting to see that number jump to 60 after refreshing the health report. It did not:

Vital Stats

    version22.0a1
    time open2 minutes
    last crash2012-10-23
    bookmarks57

Neither did the raw data:

"org.mozilla.places.places": {
          "_v": 1,
          "bookmarks": 57,
          "pages": 25097
        },

T
(Reporter)

Updated

5 years ago
Blocks: 856843
(Reporter)

Updated

5 years ago
Summary: [FHR] FHR addons not correct → [FHR] FHR bookmarks not correct
The report is not live data.  It is based on the last recorded payload.  Check tomorrow and see if the number has gone up.  If it does, then this one bug is likely a works as intended.
So, I have added a test to the codebase for bookmarks and it passes as expected with single or multiple sessions.

Updated

5 years ago
No longer blocks: 856802

Comment 3

5 years ago
Removing unrelated dependencies
No longer depends on: 856804, 856815, 856310

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
QA verified worksforme per comment 1 and comment 2. This feature appears to work as designed.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

5 years ago
Blocks: 857207
(Reporter)

Comment 5

5 years ago
 (In reply to Daniel Einspanjer :dre [:deinspanjer] from comment #1)
> The report is not live data.  It is based on the last recorded payload. 
> Check tomorrow and see if the number has gone up.  If it does, then this one
> bug is likely a works as intended.

Just FYI, I looked at my raw data today, and the date is now updated (4/2), but the bookmark count is still 57. I verified that the new bookmarks show up in the bookmarks menu:

{
  "version": 2,
  "thisPingDate": "2013-04-02",
  "geckoAppInfo": {
    "_v": 1,
    "vendor": "Mozilla",
    "name": "Firefox",
    "id": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
    "version": "22.0a1",
    "appBuildID": "20130401030817",
    "platformVersion": "22.0a1",
    "platformBuildID": "20130401030817",
    "os": "Darwin",
    "xpcomabi": "x86_64-gcc3",
    "updateChannel": "nightly"
  },

...

       "org.mozilla.places.places": {
          "_v": 1,
          "bookmarks": 57,
          "pages": 25097
        },
        "org.mozilla.searches.counts": {
          "_v": 2,
          "google.urlbar": 10
        },
        "org.mozilla.appInfo.appinfo": {
          "_v": 2,
          "isBlocklistEnabled": 1,
          "isDefaultBrowser": 1,
          "isTelemetryEnabled": 1
        },
        "org.mozilla.appInfo.versions": {
          "_v": 2,
          "appVersion": [
            "22.0a1"
          ],
          "platformVersion": [
            "22.0a1"
          ],
          "appBuildID": [
            "20130331030859"
          ],
          "platformBuildID": [
            "20130331030859"
          ]
        }
      },
      "2013-03-31": {
        "org.mozilla.searches.counts": {
          "_v": 2,
          "google.urlbar": 3
        },
        "org.mozilla.appSessions.previous": {
          "_v": 3,
          "cleanActiveTicks": [
            1637
          ],
          "cleanTotalTime": [
            125578
          ],
          "main": [
            63
          ],
          "firstPaint": [
            857
          ],
          "sessionRestored": [
            4027
          ]
        }
      },
      "2012-10-23": {
        "org.mozilla.crashes.crashes": {
          "_v": 1,
          "submitted": 1
        }
      }
    }
  },
  "lastPingDate": "2013-04-02"
}
Annie,

I'm seeing consistent data for myself, and the test seems valid, but if you are still seeing incorrect results, I'd like to dig further.

I don't know how QA feels about re-opening verified bugs, so I'll just ask if you can give me a full copy of your latest JSON and healthreport.sqlite via e-mail.  I also want to run a query on your places.sqlite, but don't feel comfortable asking for that, so ping me on IRC and I'll try to get you set up with the necessary SQL to run.
No longer blocks: 857207, 856843
(Reporter)

Comment 7

5 years ago
},
        "org.mozilla.places.places": {
          "_v": 1,
          "bookmarks": 60,
          "pages": 25234
        },

Today they both budged. I am willing to let this go for now. There does seem to be a huge lag though.

Updated

5 years ago
Component: General → about:healthreport
Product: Webtools → Firefox Health Report
You need to log in before you can comment on or make changes to this bug.