If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

External Links Always Open in A New Non-Private Window

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: Yaron, Unassigned)

Tracking

20 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

Open a new PB window and close all other windows.
Open a link from another program (POP Peeper, Outlook).


Actual results:

Fx always opens the link in a new non-private window regardless of any setting in about:config.
(Reporter)

Updated

5 years ago
Summary: Eternal Links Always Open in A New Non-Private Window → External Links Always Open in A New Non-Private Window

Comment 1

5 years ago
Yes, this is an intentional design choice from bug 829180.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

5 years ago
Could you add a setting to allow the user to choose in which mode to open external links?

Thanks.

Updated

3 years ago
Duplicate of this bug: 947625

Updated

3 years ago
Duplicate of this bug: 1020724
You need to log in before you can comment on or make changes to this bug.