Closed Bug 856872 Opened 7 years ago Closed 7 years ago

[SeaMonkey] test_feed_discovery.html | Test timed out.

Categories

(SeaMonkey :: Feed Discovery and Preview, defect)

defect
Not set

Tracking

(seamonkey2.19 fixed)

RESOLVED FIXED
seamonkey2.20
Tracking Status
seamonkey2.19 --- fixed

People

(Reporter: mcsmurf, Assigned: mcsmurf)

Details

Attachments

(1 file)

The test_feed_discovery.html test currently times out due to an JS error:
JavaScript error: http://mochi.test:8888/tests/suite/browser/test/feed_discovery.html, line 92: XPCNativeWrapper is not defined

This should get fixed. Not sure when this line
line 92 -- feeds[XPCNativeWrapper.unwrap(aFeed).href] = true;

broke.
OS: Windows XP → All
Hardware: x86 → All
> line 92: XPCNativeWrapper is not defined
The Firefox version feed_discovery.html never had this line.
Hg blame says this was added in http://hg.mozilla.org/comm-central/rev/cbb67232177d
CC Neil
BTW: This is a regression as the test did not fail a few days, this broke here http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e4d8e21d0788&tochange=1932c6f78248
Bug 855922 looks a bit related, but not really sure about that. And if it's a bug in the test code or a bug/regression from another bug.
No idea what that was about, but feel free to back that change out if it works.
Attached patch PatchSplinter Review
Test works again with this patch, will check in when tree is open.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Comment on attachment 733916 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): Bug 790732
User impact if declined: -
Testing completed (on m-c, etc.): Works on comm-central
Risk to taking this patch (and alternatives if risky): Test-only fix
String changes made by this patch: -
Attachment #733916 - Flags: approval-comm-aurora?
Target Milestone: --- → seamonkey2.20
Comment on attachment 733916 [details] [diff] [review]
Patch

a=me
Attachment #733916 - Flags: approval-comm-aurora? → approval-comm-aurora+
Pushed to comm-aurora: https://hg.mozilla.org/releases/comm-aurora/rev/b1300210da7e
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.