Bookmarks Manager hangs after every action

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: landis, Unassigned)

Tracking

22 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme] [testday-20130607])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20130401 Firefox/22.0
Build ID: 20130401030817

Steps to reproduce:

open bookmark manager 
cut > paste OR
right-click > insert separator OR
drag and drop bookmark 


Actual results:

FF hangs.
I can mouse scroll the scroll bar, but the content does not move.
it takes up to 90 secs for the content to 'refresh' and scroll 
or to be able to preform another task such as move, cut, modify url of description of a bookmark or insert separator / folder


Expected results:

there should be no (perhaps fraction of a second) delay.

*this happened to me once before and only once before did i use sync. I don't remember if i used sync last time this happened, but i know this time, i have just used sync and with the miniscule amount of control and information available for sync, the **** 'service' added 6 or 8 'addons' that are 10 months out of date. I had addon manager opens, is the only reason i know. I removed (undo) the added items. I tried restoring the backup json file i made just before sync, but after inserting separator Bookmark Mgr still hangs for a minute or so.

my two cents... sync sucks.
Landis.
(Reporter)

Comment 1

6 years ago
Created attachment 732253 [details]
during restore of json file bm mgr hangs

during the restore of json file, Bookmark Manager (library) hangs 6 to 10 times, and i did not write down all the script errors, but took a couple of screenshots... i have a couple others, all different codes, scripts.
Landis.
(Reporter)

Comment 2

6 years ago
I tried " echo .dump | sqlite3 places.sqlite.bak | sqlite3 places.sqlite " and there were about 1,000 lines of error similar to this, 'Error: near line 213240: column host is not unique'.
this did Not 'fix' the Bookmark Manager hanging or freezing when any action is preformed.
Again, i can scroll the scroll bar with mouse wheel, but content (the names, url, date of bookmarks page) does not move and clicking on a BM does nothing for > 1min between actions.

Again, this seems to me, having 2 similar problems of BM Library hanging twice having used sync.
(Reporter)

Comment 3

6 years ago
I've deleted (renamed, moved) places.sqlite > renamed directory 'bookmarkbackups > restarted Nightly > let it build a new places.sqlite > restored Known Good, pre sync backups.jons file and I still have Bookmarks Manager (Library) Hanging on Every action. Sometimes the hang is > 1 min.
I have a screenshot of every script error that occurred during 'restore' json file.

Landis.
(Reporter)

Comment 4

6 years ago
I have reproduced this many times.
removing things. installing new, new profiles etc.
Any combination will produce the hanging BM Library IF sync is enabled.
On anyone of the 'broken' installations, profiles, enabling mozilla sync reproduces hang.
For Sure, Every Time.

setup:
Dell 630 Latitude, 4 GB RAM, 128 MB VR, 320 GB HDD, openSuSE 12.2 (all updates), KDE 4.8.5 (all updates) mozilla FF Nightly (up to date), about:support document is at [ http://www.landisreed.com/pages/mozilla/Troubleshooting_Information_Nightly-22_010413.xhtml ], running on wireless network connected @ 48Mb/s on broadband.

Landis.
(In reply to Landis Reed from comment #4)
> Any combination will produce the hanging BM Library IF sync is enabled.

This is known (search for already filed Reports in this Component) but personally I doubt this will get fixed since Sync will be abandoned in Favor of PiCL.

https://wiki.mozilla.org/Identity/AttachedServices
Whiteboard: [dupeme]
(Reporter)

Comment 6

6 years ago
(In reply to XtC4UaLL [:xtc4uall] from comment #5)
> (In reply to Landis Reed from comment #4)
> > Any combination will produce the hanging BM Library IF sync is enabled.
> 
> This is known (search for already filed Reports in this Component) but
> personally I doubt this will get fixed since Sync will be abandoned in Favor
> of PiCL.
> 
> https://wiki.mozilla.org/Identity/AttachedServices

Thank you. I thought I should share what I've learned.. 
It caused me much grief not knowing it was a problem. lack of current docs at mozilla. : (
I will look into PiCL.. 
Landis.

Comment 7

6 years ago
Works fine for me using Windows 7 64 bit and the latest Beta.
Whiteboard: [dupeme] → [dupeme] [testday-20130607]

Updated

6 years ago
Component: Untriaged → Bookmarks & History

Comment 8

4 years ago
Closing WFM per comment 7
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.