Random crashes when installed on SSD

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
--
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Billy Yop, Unassigned)

Tracking

({crash, stackwanted})

19 Branch
x86
Windows 7
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 732258 [details]
bp-062d2a6e-4c9f-4125-9f05-49d322130402.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

I was reading a text on a webpage, not using mouse or keyboard, just reading


Actual results:

Firefox crashes back to desktop and launched crash reporter


Expected results:

It shouldn't have crashed. Already tried multiple profile reset and even a clean reinstallation. only kept my favorites with mozbackup. It kept crashes, even with no extension, in its genuine state. 
Memory leak (have 8go) may be a clue, since firefox strangely uses well above 2go sometimes (even with simple text pages opened). couldn't see if it's related to the crashes though.
(Reporter)

Comment 1

5 years ago
tested memory with memtest, no error detected
(Reporter)

Comment 2

5 years ago
Avg free antivirus and comodo firewall update, i try to desactivate spybotSD resident protection to see if it solves
(Reporter)

Comment 3

5 years ago
Just had another crash while on this bugzilla page, so spybotSD resident is not the cause
(Reporter)

Comment 4

5 years ago
latest crash report : https://crash-stats.mozilla.com/report/index/d15abca2-df2a-4d02-8598-3855a2130402
(Reporter)

Comment 5

5 years ago
latest crash report : https://crash-stats.mozilla.com/report/index/bp-2c8bd797-3bb4-40f3-833f-36a6b2130402
The crash reports are unfortunately empty and useless for us.
Seems something 3rd Party kills your Firefox Install/Session.
That's the Reason "Reinstall"/"New Profile" does not help.

No Stacks on the given CrashIDs either.

My Advice would be to stop any non-MS Services/Autoruns (including but not only Anti-Virus Stuff) and see if it takes you further.
Flags: needinfo?(billyopyop)
(Reporter)

Comment 8

5 years ago
Thank you I really didn't know what to do. So i'll take this step : with msconfig i'll uncheck on by one all non-ms on the services and startup page.
I'll tell you if it worked
Flags: needinfo?(billyopyop)
(Reporter)

Comment 9

5 years ago
Can't believe this bug : 
So i run Msconfig.exe, i disabled all non ms stuff in services, including ati and intel. on the startup page i disabled everything.
Still had a crash seconds ago !
As i said i had already tried reseting ff in genuine state, and still had crashes. since then i had reinstall some extension. So i guess i can now ff in safe mode see if ther's a change.
otherwise next step i thought was running windows in safe mode, with network, and inside that run also ff in safe mode ?
(Reporter)

Comment 10

5 years ago
So I ran windows in safe mode with network, ran firefox in safe mode as well.
And firefox crashes after about 10 minutes being opened, not even surfing as usual it just crashes "all alone"
Really crazy bug.
Thought of a thing : firefox is installed on the system drive, ssd drive.
I'll try a clean install on a classic hdd drive.
After that i guess i can only reinstall windows. It should (or i'm cursed) solve it, but for bugzilla we'll never know what caused it.

Comment 11

5 years ago
If you haven't reinstalled windows yet, could you try (with a new profile) going to about:config and setting the value of layers.acceleration.disabled to false.

Also, go to add-ons manager, disable all your plugins and double-check that you have no extensions installed.

Once you've done the above, restart the browser and see if you're still experiencing the leak.
(Reporter)

Comment 12

5 years ago
I think I got something : since i move firefox installation dir from the system drive (ssd drive from kingston : SV100s232G) to a classic hard drive, I had no crash of all the afternoon.
...Finally i may have found the damn reason why, i was going mad... Now me happy, me use my firefox again :) i use it happily since 2000 !
I made a quick search it seems there's a problem with the cache being on a ssd drive in some cases.
If it's usefull I can try to give more informations here so that this bug can be reproduced.
I'll wait till tomorrow before putting this bug as solved, just in case.
I'm not a programer, i would say average user, so thanks to the kind people who helped me here.
(Reporter)

Comment 13

5 years ago
Still no crash...
Another clue : firefox was using a lot of ram (as indicated in task manager) when i had the crashes. Usually more than 2Go. I have 8Go installed so it wasn't a problem but was weird. Even with no extension and only one tab.
Now, since i changed the installation drive, i'm between 200 and 300 Mo, that is more "normal" i guess.
(Reporter)

Comment 14

5 years ago
Another crash seconds ago :(
Same empty crash report.

I will try to move the cache directory using Browser.cache.disk.parent_directory from the users folder in the ssd drive to the hdd drive.

And if i format, i'll try what you advise IU. For information, on this install the layers.acceleration.disabled value is on false.

Comment 15

5 years ago
Please provide a valid stack trace (see https://developer.mozilla.org/docs/How_to_get_a_stacktrace_with_WinDbg) although I assume you will find a different stack trace at each run (corrupted RAM gives that result).
Severity: normal → critical
Flags: needinfo?(billyopyop)
Keywords: crash, stackwanted
Hardware: x86_64 → x86
Summary: Crashes even after total reset or reinstall → Random crashes when installed on SSD
(Reporter)

Updated

5 years ago
Hardware: x86 → x86_64
(Reporter)

Comment 16

5 years ago
I spent hours trying to install windbg. Finally succeeded.
I'm runing it and monitoring firefox. Will post stack trace as soon as ff crashes
But i had no other crash since last step i took : changing the cache directory from ssd to hdd drive. Hope that was the solution, though i doubt it.
For the moment I keep firefox open with windbg.
And i don't think I have corrupted RAM, i ran Memtest who reported nothing, and i have no other ram related issues in other programs.
To clarify specs : Win7 64 bit Ultimate, Mb GA-Z68X-UD3H-B3, Intel core i5 2500k, 8go ram, ssd kingston SV100S232G, Ati HD6870.
Flags: needinfo?(billyopyop)

Comment 17

5 years ago
(In reply to Billy Yop from comment #16)
> I'm runing it and monitoring firefox. Will post stack trace as soon as ff
> crashes
> But i had no other crash since last step i took : changing the cache
> directory from ssd to hdd drive. Hope that was the solution, though i doubt
> it.
Please run WinDbg when Firefox has its cache on SSD in order to make Firefox crash.
Hardware: x86_64 → x86

Updated

5 years ago
Flags: needinfo?(billyopyop)
(Reporter)

Comment 18

5 years ago
First of all I had one crash even with the cache directory on hdd. It was more stable but crashed once.
But the important point is that I finally had multiple problems, with install processes of programs, with my antivirus getting buggy and so on.
So i concluded my windows was messed up, and I format my drive so i could use my pc again.
And more importantly Firefox was not the cause but i guess it was just a consequence of my system having problems. I reinstalled FF, on hdd, with cache still on ssd, and up to now i had no crash
We can close this bug i think. Thanks for the help, and long live Firefox !
Flags: needinfo?(billyopyop)
Thanks for the feedback and it really looks like that this was a system issue -> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.