Closed Bug 857036 Opened 8 years ago Closed 8 years ago

excessively large numbers in maildb memory reporter for mailnews

Categories

(MailNews Core :: Backend, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 805023

People

(Reporter: wsmwk, Unassigned)

References

Details

+++ This bug was initially created as a clone of Bug #480843 +++

After an hour or so some of the maildb with a warning from about:memory. The  negative heap-unclassified is covered in another bug.

WARNING: the following values are negative or unreasonably large.
 explicit/maildb
 explicit/maildb/database(imap://vseerror@mail.lehigh.edu/Moz)
 explicit/heap-unclassified


135.50 MB (100.0%) -- explicit
├──652.29 MB (481.38%) -- maildb [?!]
│  ├──348.64 MB (257.29%) ── database(imap://vseerror@mail.lehigh.edu/Moz) [?!]
│  ├──128.00 MB (94.47%) ── database(imap://wsm0@mail.lehigh.edu/INBOX)
│  ├──125.02 MB (92.26%) ── database(imap://vseerror@mail.lehigh.edu/INBOX)
...

└──-527,258,176 B (-420.31%) ── heap-unclassified [?!]
I have one with :

 ├──1,467.18 MB (67.52%) ── database(imap://lhirlimann%40mozilla.com@mail.mozilla.com/Infra%27s%20Inbox/Cron/DNS%20and%20DHCP)
│  ├────285.85 MB (13.15%) ── database(imap://ludovic%40hirlimann.net@imap.googlemail.com/%5BGmail%5D/All%20Mail)
│  ├────170.59 MB (07.85%) ── database(imap://lhirlimann%40mozilla.com@mail.mozilla.com/Bugs)
│  ├─────74.04 MB (03.41%) ── database(imap://lhirlimann%40mozilla.com@mail.mozilla.com/My%20bugs)
│  ├─────73.27 MB (03.37%) ── database(imap://ludovic%40hirlimann.net@imap.googlemail.com/INBOX)
│  ├─────65.43 MB (03.01%) ── database(imap://ludovic%40hirlimann.net@imap.googlemail.com/Bugs)
│  ├─────51.08 MB (02.35%) ++ (11 tiny)
│  └─────31.83 MB (01.46%) ── database(imap://lhirlimann%40mozilla.com@mail.mozilla.com/INBOX)
Always with IMAP?
(In reply to :aceman from comment #2)
> Always with IMAP?

Looks like it.
(In reply to Wayne Mery (:wsmwk) from comment #0)
> +++ This bug was initially created as a clone of Bug #480843 +++
> 
> After an hour or so some of the maildb with a warning from about:memory. The
> negative heap-unclassified is covered in another bug.
> 
> WARNING: the following values are negative or unreasonably large.
>  explicit/maildb
>  explicit/maildb/database(imap://vseerror@mail.lehigh.edu/Moz)
>  explicit/heap-unclassified

I don't 100% trust all the numbers I'm getting, but MOZ_DMD isn't working correctly for us right now, so I can't debug which allocations are getting overreported.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 805023
You need to log in before you can comment on or make changes to this bug.