lynda.com serves wrong wap content type to firefox for Android

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: don.albertson, Assigned: karlcow)

Tracking

Trunk
ARM
Android

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-us] [serversniff] [http] [wml] [contactready], URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

entered url 
lynda.com


Actual results:

Page says please enable javascript.
Page also consumes entire screen and does not display Firefox menu/tab bar
FWIW full version is 19.0.2


Expected results:

It should have done what Chrome does -- display the page with usable login features.

Comment 1

6 years ago
(In reply to Don Albertson from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101
> Firefox/19.0
> Build ID: 20130307023931
> 
> Steps to reproduce:
> 
> entered url 
> lynda.com
> 
> 
> Actual results:
> 
> Page says please enable javascript.
> Page also consumes entire screen and does not display Firefox menu/tab bar
> FWIW full version is 19.0.2
> 
> 
> Expected results:
> 
> It should have done what Chrome does -- display the page with usable login
> features.

I just tried http://lynda.com with Firefox Mobile and it dowloaded something. Why?
(In reply to mausganymed from comment #1)
> (In reply to Don Albertson from comment #0)
> I just tried http://lynda.com with Firefox Mobile and it dowloaded
> something. Why?

The site is serving [application/vnd.wap.xhtml+xml] as a content-type to the browser which Gecko and Android doesn't know how to handle. Firefox for Android does not support WAP.

The author of the website will need to recognize that Firefox for Android is a modern browser that is more than capable of working with their mobile optimized version (using HTML) that they specifically are sending to Chrome.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

6 years ago
So it's a case of "they expect a WebKit browser" or is this a replay of the I.E. vs. Netscape battles of the previous decade?
(In reply to Don Albertson from comment #3)
> So it's a case of "they expect a WebKit browser" or is this a replay of the
> I.E. vs. Netscape battles of the previous decade?

Both of those end up in "doesn't run in my browser". In this case, it's likely lynda.com is "mobile-ready". In fact, I see they have an m.lynda.com but they are sending two types of "mobile" content:

1. One for new mobile browsers
2. One for old feature phone browsers (WAP)

The trouble is, it seems to be sniffing for certain browsers and only sending those browsers the good mobile content (#1). All other mobile browsers get the old WAP content (#2).

I installed a UA switcher in Firefox desktop. I set it to use Firefox for Android UA and I get the same download of WAP content. If I then switch to use Chrome for Android UA, I get the real mobile website. I looked at the code and I did not find a webkit-specific website. It looks like it should work fine in Firefox.

lynda.com should include Firefox for Android in it's "OK for new mobile content" list.
We could REOPEN this bug and move it to Tech Evangelism.
Assignee: nobody → english-us
Status: RESOLVED → REOPENED
Component: General → English US
Ever confirmed: true
Product: Firefox for Android → Tech Evangelism
Resolution: INVALID → ---
Version: Firefox 19 → Trunk
(Assignee)

Comment 6

4 years ago
So if I understood the bug, this was when using Firefox on Android.
When faking the UA the site still exhibits the same issue.
It tries to redirect to m.lynda.com and then serve the wrong Content Type.

1. First Request

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Host: www.lynda.com
User-Agent:  Mozilla/5.0 (Android; Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

HTTP/1.1 301 Moved Permanently
Cache-Control: no-cache
Date: Mon, 29 Sep 2014 10:00:53 GMT
Expires: -1
From: 501422-web5
Location: http://m.lynda.com/default.aspx?rp=http%3a%2f%2fwww.lynda.com%2fdefault.aspx
Pragma: no-cache
Server: Microsoft-IIS/7.5
Set-Cookie: BigIP-F5=3640764608.20480.0000; path=/
Transfer-Encoding: chunked
X-AspNet-Version: 4.0.30319
X-AspNetMvc-Version: 2.0
X-Powered-By: ASP.NET

2. Redirection

GET /default.aspx?rp=http%3a%2f%2fwww.lynda.com%2fdefault.aspx HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Host: m.lynda.com
User-Agent:  Mozilla/5.0 (Android; Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

HTTP/1.1 200 OK
Cache-Control: private
Content-Encoding: gzip
Content-Length: 3623
Content-Type: application/vnd.wap.xhtml+xml; charset=utf-8
Date: Mon, 29 Sep 2014 10:01:52 GMT
From: 501426-WEB9
Server: Microsoft-IIS/7.5
Set-Cookie: ASP.NET_SessionId=01eoab1hkfw0bs2dk1xnorri; path=/; HttpOnly
Set-Cookie: ASP.NET_SessionId=01eoab1hkfw0bs2dk1xnorri; path=/; HttpOnly
Set-Cookie: token=0bd5bb44-e09f-4f24-bd15-20d18ad993f1,7496a28311603823eeb0eded9ee2b5da,9IjP9qRQr6VMuo7ZgzobTKgINJewMycdzvMl0eYHKI893xQaZ1I8jPH2eqFTKtqtI2iue0flXmCwkVbSxM2K8jgpAm3uFZ44s+9bVyx+t8ieRMWOqUl8eKaJXOoRcSFO; expires=Mon, 29-Sep-2014 14:01:52 GMT; path=/; HttpOnly
Set-Cookie: LyndaLoginStatus=Unknown Not Logged-In; domain=.lynda.com; expires=Sun, 29-Sep-2024 10:01:53 GMT; path=/
Set-Cookie: BigIP-F5=1661053120.20480.0000; path=/
X-AspNet-Version: 4.0.30319
X-AspNetMvc-Version: 2.0
X-Powered-By: ASP.NET


To note that we have also another bug where this behavior was already identified. But it's not entirely a duplicate. Bug 964080
Assignee: english-us → nobody
Component: English US → Mobile
OS: Windows 7 → Android
Hardware: x86_64 → ARM
See Also: → bug 964080
Summary: Lynda.com says javascript not enabled. (OK on desktop OK in Chrome Android) → lynda.com serves wrong wap content type to firefox for Android
Whiteboard: [country-us] [serversniff] [http]
(Assignee)

Updated

4 years ago
Assignee: nobody → kdubost
Status: REOPENED → ASSIGNED
seems like this is a blocker for that one - no point in fixing their redirect for Firefox OS if it's just going to get a WAP/wml site instead of the desktop
Blocks: 964080
Whiteboard: [country-us] [serversniff] [http] → [country-us] [serversniff] [http] [wml]
Whiteboard: [country-us] [serversniff] [http] [wml] → [country-us] [serversniff] [http] [wml] [contactready]
(Assignee)

Comment 8

4 years ago
to note that when faking chrome mobile on Gecko
http://m.lynda.com/default.aspx?rp=http%3a%2f%2fwww.lynda.com%2fdefault.aspx

The site we receive is perfectly usable. This is really just wrong UA sniffing and wrong mime-type handling.
(Assignee)

Comment 9

4 years ago
contactform
I contacted them again with 
http://m.lynda.com/about/sitefeedback
(Assignee)

Comment 10

4 years ago
> Your ticket number is [001-1C353C3A-DE67].
> Please allow one (1) business day for a response.

Comment 11

4 years ago
Came up again on the forums, https://support.mozilla.org/en-US/questions/1042304
(Assignee)

Comment 13

4 years ago
I didn't hear anyone back wrt the ticket in Comment #10
The individual mentioned by David in the tweet from Comment 12 said he forwarded it to the web team.
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.