Link to facebook friend not imported previously fails on v1.0.1

VERIFIED FIXED

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: crdlc, Assigned: crdlc)

Tracking

({regression})

unspecified
x86
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 unaffected, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

188 bytes, text/html
Jose Manuel Cantera
: review+
crdlc
: feedback+
Details
(Assignee)

Description

5 years ago
E/GeckoConsole( 3455): [JavaScript Error: "TypeError: can't convert undefined to object" {file: "app://communications.gaiamobile.org/contacts/js/fb/fb_import.js" line: 786}]
(Assignee)

Updated

5 years ago
Assignee: nobody → crdlc
blocking-b2g: --- → leo?
Depends on: 849186
Keywords: regression
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
blocking-b2g: leo? → tef?
(Assignee)

Comment 1

5 years ago
Created attachment 732369 [details]
Patch v1

STR

Create a new contact called Manolo. Go to details and click on 'link contact' button. Wait your suggestions and click on one friend what haven't been imported previously
Attachment #732369 - Flags: review?(jmcf)
Attachment #732369 - Flags: feedback?(gtorodelvalle)
(Assignee)

Updated

5 years ago
status-b2g18-v1.0.1: --- → affected

Updated

5 years ago
Attachment #732369 - Flags: review?(jmcf) → review+
Hi Cristian! Works perfectly fine when pulled into v1.0.1. Thanks! ;-)
(Assignee)

Comment 3

5 years ago
Comment on attachment 732369 [details]
Patch v1

The feedback is + because German says it works fine, thanks
Attachment #732369 - Flags: feedback?(gtorodelvalle) → feedback+
(Assignee)

Comment 4

5 years ago
Commit in v1.0.1

https://github.com/mozilla-b2g/gaia/commit/3e362124fb8b1745e074957a336c1795535766d6

This bug is only reproducible on v1.0.1!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-b2g18-v1.0.1: affected → fixed
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
status-b2g18: --- → unaffected

Updated

5 years ago
blocking-b2g: tef? → tef+

Comment 5

5 years ago
The issue is fixed on Unagi Build ID: 20130404070204
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/e43e65ec89d2
Gaia: daea430624ec02f8d36a12d581fc4a3278c27cb7

User is able to Link selected Facebook contact to the Contact (Manolo).
Verified Fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.