Importing a google calendar event with a 10 minute and 20 minute alarm reminder - no alarm reminders shown on device

RESOLVED INVALID

Status

Firefox OS
Gaia::Calendar
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: lightsofapollo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Build: B2G 18 4/2/2013
Device: Unagi

STR

1. Import a google calendar that contains an event with a 10 minute and 20 minute alarm reminder
2. View that event

Expected

The calendar event imported should have 2 alarm reminders.

Actual

The calendar event imported has no alarm reminders.
(Reporter)

Updated

5 years ago
Whiteboard: [gaia-leo?]
(Assignee)

Comment 1

5 years ago
Does this reproduce with Yahoo or Zimbra?
(Reporter)

Comment 2

5 years ago
(In reply to James Lal [:lightsofapollo] from comment #1)
> Does this reproduce with Yahoo or Zimbra?

This isn't going to be possible on Zimbra, as Zimbra only supports a single alarm. Yahoo doesn't have a 10 min & 20 minut alarm reminder, so this can't happen there either. This bug is only possible with google calendar.
(Reporter)

Comment 3

5 years ago
Double checked - still reproducible on 5/12
blocking-b2g: --- → leo?
Whiteboard: [gaia-leo?]
(Assignee)

Comment 4

5 years ago
There is a bug in google's implementation where altering the alarm information does not change the event's etag. This means if you do something like this:

-> create event
-> sync
-> edit alarm
-> sync

We will not know about changes to this event until some other details are altered.
James, should we fix this on our side or is it on Google side ? Does it occurs on tef version too ?
Flags: needinfo?(jlal)
(Reporter)

Comment 6

5 years ago
(In reply to David Scravaglieri [:scravag] from comment #5)
> James, should we fix this on our side or is it on Google side ? Does it
> occurs on tef version too ?

From my experience, Google is tough to get fixes from given that FF OS has low market share. We need to try to get a fix on our side if possible, even if it means implementing a workaround.
(Assignee)

Comment 7

5 years ago
I have made an informal request (to their Calendar team) we might get better results when we switch to https://bugzilla.mozilla.org/show_bug.cgi?id=871302 for sync... Its worth doing some experimenting.
Flags: needinfo?(jlal)
(Reporter)

Comment 8

5 years ago
Looks like this reproduces with all-day events too. Specifically, any case with events with two or more alarms for google calendar events.

Comment 9

5 years ago
(In reply to Jason Smith [:jsmith] from comment #8)
> Looks like this reproduces with all-day events too. Specifically, any case
> with events with two or more alarms for google calendar events.

Hi Jason,

I was unable to reproduce this. These where the steps I took:

1) on desktop, I added both an all day event and an one hour event to google calendar,  each with their respective 10 and 20 alarms
2) on device (unagi) I import the same google calendar
3) check calendar event details view for both events
4) each show the 10 and 20 min alarms

Enviroment info:
Build: 20130505070205
Gaia: 753e7d6

Hopefully, I'm taking the right steps to test this bug, else I'm convinced my phone is from the future :)  Let me know if you any addition info.

Thanks,
Mark
(Reporter)

Comment 10

5 years ago
Hmm...that might good news actually if you can't reproduce. I've reproduced this 3 times over 3 different builds with one google account. Which means this might be a problem specifically at the caldav layer with parsing my calendars for that account.

Let me try my other google account if I can reproduce. If I can't, then that confirms my theory above.
Keywords: qawanted
QA Contact: jsmith
(Reporter)

Comment 11

5 years ago
I can reproduce this with my other google account as well. So yeah, I'm not sure why you can't reproduce.
Keywords: qawanted
QA Contact: jsmith
blocking-b2g: leo? → leo+
Assignee: nobody → jlal
(Reporter)

Updated

5 years ago
See Also: → bug 857288
(Reporter)

Comment 12

5 years ago
Turns out I found out why this wasn't working for me. Gcal supports two styles of alarms:

- Email
- Popup

We integrate with popup, given those are the type of notifications we fire. Upon further testing, those appear to work in single, 2 alarm, and 5 alarm cases. That explains the issues I hit here.

Resolving as invalid as we technically import the popup alarms, not the email alarms (which makes sense).
Status: NEW → RESOLVED
blocking-b2g: leo+ → ---
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.