All users were logged out of Bugzilla on October 13th, 2018

Tab counter animation delayed until toolbar is visible again

VERIFIED FIXED in Firefox 22

Status

()

VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: kats, Assigned: sriram)

Tracking

22 Branch
Firefox 23
All
Android
Points:
---

Firefox Tracking Flags

(firefox22 fixed, firefox23 verified)

Details

Attachments

(1 attachment)

Cameron says:

--
When you open some tabs in  the background while the address bar is not shown (because you've  scrolled down the page), the animations to show the new number of tabs  is triggered when you scroll up a bit to reveal the address bar.  This  can be some time after the tabs were opened, so it seems a bit odd to  have the animation; it feels like it is saying that the tabs were just  opened, which isn't the case.
--

I can reproduce, and agree it looks wrong. Not sure if this is a sriram "animation" bug or a Cwiiis "dynamic toolbar" bug. Perhaps some collaboration is in order.
(Assignee)

Comment 1

6 years ago
Is the expected behavior not to animate with the BrowserToolbar is hidden?
(Assignee)

Comment 2

6 years ago
Created attachment 732579 [details] [diff] [review]
Patch

I couldn't reproduce it. But here is a patch. If the browsertoolbar isn't visible or animating, we default to updateTabsCount() if even updateTabsCountAndAnimate() was called.
Attachment #732579 - Flags: review?(mark.finkle)
Comment on attachment 732579 [details] [diff] [review]
Patch

Seems safe, but I'd like to get it verified.
Attachment #732579 - Flags: review?(mark.finkle) → review+
I tested the patch locally and it worked fine.
https://hg.mozilla.org/mozilla-central/rev/11bd7d1bbe0d
Assignee: nobody → sriram
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
(Assignee)

Comment 8

6 years ago
Comment on attachment 732579 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Dynamic toolbar.
User impact if declined: The animation might happen when the browser toolbar is shown sometime later after open a tab in background.
Testing completed (on m-c, etc.): Landed in m-c on 04/03
Risk to taking this patch (and alternatives if risky): None. :P If the view isn't visible "y u animate?"
String or IDL/UUID changes made by this patch: None.
Attachment #732579 - Flags: approval-mozilla-aurora?

Updated

6 years ago
Attachment #732579 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/ba4b5ba5492b
status-firefox22: --- → fixed
status-firefox23: --- → fixed

Comment 10

5 years ago
Firefox for Android 23.0b2 (2013-07-02)
Device: LG Optimus 4x 
OS:Android 4.1.2
Status: RESOLVED → VERIFIED
status-firefox23: fixed → verified
You need to log in before you can comment on or make changes to this bug.